Alerts - not receiving email

I am able to send “test” notification but actual breaches not sending notification.
Any ideas?
I am using NRQL.

Hi @KokFen.Chia, you can set up email notifications by following the directions in this documentation. Double check to see if you have followed all the steps and let me know if that does not work.

Hi,
I don’t see your link.

Sorry about that @KokFen.Chia, you should be able to find the documentation here.

Hello,
I have changed the subject from “Alerts - not sending email” to “Alert - not triggering”.

The real issue is that it is not triggering…

It is obvious from the chart, it should trigger BUT it is not.

FYI, the NRQL is AWS datastoresample - i.e RDS instance.

HI,
OK, I am able to get the triggering to work by doing the following:
Infrastructure => Settings => Alerts => Create alert conditions.
This seemed to trigger and send email.

BUT if I choose to use:
alerts & AI => Policies => New Alert Policy and subsequently put the desired NRQL… it does not trigger.

Why?

Thx.

Hi @KokFen.Chia,

I see you mentioned that you’re working with AWS data here. We commonly see issues where Alerts violations aren’t opened for customers using these data types if their evaluation offset it too low. Specifically, this data has a tendency to be latent and this requires a bit of extra configuration to work as intended. For more background on this, see this resource: Relic Solution: Better Latent Than Never – How Data Latency Affects NRQL Alert Conditions.

My suggestion would be to go to “Advanced Signal Settings” on this condition page and offset your query by 15 minutes (this is 15 windows if you’re using default settings). While this may seem like long offset, it’s generally necessary for reliability with AWS data because of the latency issues that I referenced previously. Feel free to give this a shot and let me know if it works for you here!

2 Likes

Masen,
Thx, it worked.
And the portal explained a lot.

Hi KokFen.Chia

I am also facing the issue. Alert emails are not triggering for me.

In addition to alerts & AI => Policies => New Alert Policy and subsequently put the desired NRQL, do we need to setup Infrastructure => Settings => Alerts => Create alert conditions also?

 How did you solve this issue? Please help and guide me.

My config as as below:

Try as per suggestion -
“Advanced Signal Settings” on this condition page and offset your query by 15 minutes (this is 15 windows if you’re using default settings).

In my case I am using AWS data - NOT new relic agent.

I have given it like this:
Is this what it means by offset query by 15 minutes?