Android Phones Not Receiving Alert Push Notifications

MY android users do not appear to be getting push notifications from the alert policies but my iPhone users are. I myself am on android and confirmed that I do not get any triggered notifications OR test notifications. One of my users who identified the problem logged into the app on android and iphone and when i sent a test push it registered both devices and said it sent to “2 devices” but only the iPhone received the push notification.

2 Likes

Anyone else experiencing this?

Hey @travissimpson

It looks like we had some other reports of similar behavior with the Android app. NR Support has since filed a ticket with our app development team to investigate further.

I will share the usual steps to resolve most app issues, but if this is a result of something larger, our team will need to release a fix in an upcoming app version.

  1. Uninstall the New Relic app from your mobile device
  2. Remove the device from New Relic by logging into New Relic on your computer and following the delete instructions in this document
  3. Reinstall the New Relic app to your mobile device
  4. Log in to New Relic using the New Relic mobile app
  5. Use the ‘Send test notification’ option in the app to test the push notification functionality

Thanks for your reply @dmurray . We had previously done all but #2 in that list however I deleted the whole user too and reinvited at one point, would that have achieved the same goal of #2 since the whole user was deleted?

I would think that creating a new user would typically be an effective alternative, but this definitely sounds like its related to the bug that’s been filed. I’ll keep tabs on progress!

1 Like

Same issue for me. Following instruction from https://docs.newrelic.com/docs/mobile-apps/new-relic-mobile-apps/authentication-alerts/alerting-new-relic-mobile-apps doesn’t help. Test notification from the app works fine, but test notification from the site never appears at the phone.
Also, the deviceID (from GraphQl request actor → mobilePushNotification → devices → deviceId) remains the same after deleting device/uninstall app/reinstall. Is it somehow related

Any updates on this issue? I have been experiencing it as well.

Following the instructions provided I experienced the same as @victor.polozov

  • Device ID doesn’t change after it has been removed and re-added
  • Test notification from within the app works
  • Test notification initiated from the server does not work

Following up on this thread, New Relic for Android version 3.11.0 has been released and addresses this issue with notification failures. Release notes here: Mobile app for Android v3.11.0 | New Relic Documentation

My end user who reported the issue and myself just downloaded the update and sent a test notification and it was NOT received by either of us. I’ll wait to see if a real alert gets triggered when something reports as down but I’m not optimistic since the test did not work. Are any other steps required other than downloading the update?

Thank you for the response. I am using v3.11.0 of the android app and had a real incident trigger this morning and did not receive the push notification. I also tried with the test notification and that didn’t work either.

Was there anything additional that needed to be done with the new version to get it working?

@karl16 @travissimpson
You should only need to install the update, but please review the delete > reinstall/troubleshooting steps here: Alerting with New Relic mobile apps | New Relic Documentation

If notifications still aren’t sent after going through the troubleshooting steps, please let me know so I can notify our engineering team.

I’ve got no notifications with updated app as well. Following troubleshooting instructions also didn’t help.

Same as the others, still doesn’t appear to be resolved.

This a pretty core feature as we use New Relic synthetic monitors to notify of outages. No push notifications severely hamper one of the core features. Can this be escalated as it’s been open for a month and impacting our operations?

1 Like

Hi @jasonbrito Our engineering team is aware that the push notifications for Android are still not functioning properly and are working on a fix for this. While I cannot provide an exact time when this fix will be implemented, I can assure you that we take our commitments seriously.

@jasonbrito Our engineers have just released a bug fix for the Android app push notifications. Go ahead and install the new version and please let us know if you run into any troubles! Mobile app for Android v3.12.1 | New Relic Documentation

Still not working for me with v3.12.1

Does not work for me either, I confirmed I am on 3.12.1

It’s not working for me also using v3.12.1. I tried all of those recommended steps but I got no success. Are NR Team working on it? I migrated from IOS to Android and I’m missing a lot the Alert notifications and this is really annoying…

Hi @gabriel.carmo our engineering team is aware that push notifications aren’t working with the newest v3.12.1 and are currently investigating. Please follow along on our Android mobile release notes to see if/when there has been any advancements for this issue: Mobile app for Android release notes | New Relic Documentation