Cannot create Personal API Keys via NerdGraph API explorer

Hi there,

I’m following this document:

Create personal API keys via NerdGraph API explorer

To generate an API key for a user from the NerdGraph API explorer:

  1. Navigate to and sign in if prompted.
  2. Click the “API keys” dropdown.
  3. Under “Create a new API key” , select an account.

I can’t see the account under “Create a new API key”. See below.

Please advise.

@tncla Sorry to hear you are experiencing this issue. I have reached out to our account management team to get their help. You should receive an email from them soon :slight_smile:

It turns out that I had to use the EU weblink instead of the US one (it was not mentioned in the documentation though). The problem has now been solved, thank you.

1 Like

I am running into the same issue, can you elaborate? Maybe with screenshots? I am not sure what the EU weblink is.

My account is in the EU data center ( and, as such, I had to use the EU instance of NerdGraph found here:

Let me know if this works for you.

1 Like

Thanks @tncla for your answer. That indeed solves the problem for me.

@JoiConverse could this maybe be updated in the documentation? The experience is otherwise rather frustrating.

1 Like

@dschridde Great to hear this has been solved for you. I’ll share with our docs team. Thanks @tncla :slight_smile:

I just checked and there is still at least one page which does not mention the different instance for EU customers:

For the New Relic Terraform provider I submitted a pull request: