Can't post deployment notices to New Relic One

Since moving to New Relic One, I can’t post deployment notices anymore. It worked before switching. I tried using the API explorer but it didn’t work either.

When I post a deployment notice, I get an error: “We didn’t find an application with the given ID: 79942881”. That is the app ID given in the APM when I click on (i) See metadata and manage tags.

Hey @reaanb! Thanks for posting in the community! :wave:

Could you send me the API call you’re making to post this deployment marker? Making sure to obfuscate your API key, of course.

That will help me dig in. Thanks!

Hi Maggie

Thank you for looking into this.

I’m using the API explorer at https://rpm.newrelic.com/api/explore/application_deployments/create?application_id=79942881

Regards,

Reaan

Hi again @reaanb! Thanks for getting back to me.

I searched your account (ID: 2892502) for the application ID: 79942881, and I don’t see an application associated with that ID in your account.

Could you send me a link to the application where you’re trying to create the deployment marker?

Thanks! :smiley_cat:

Hi Maggie

Here is the link from the APM:
https://one.eu.newrelic.com/launcher/nr1-core.explorer?platform[accountId]=2892502&pane=eyJuZXJkbGV0SWQiOiJhcG0tbmVyZGxldHMub3ZlcnZpZXciLCJlbnRpdHlJZCI6Ik1qZzVNalV3TW54QlVFMThRVkJRVEVsRFFWUkpUMDU4TnprNU5ESTRPREUifQ&sidebars[0]=eyJuZXJkbGV0SWQiOiJucjEtY29yZS5hY3Rpb25zIiwiZW50aXR5SWQiOiJNamc1TWpVd01ueEJVRTE4UVZCUVRFbERRVlJKVDA1OE56azVOREk0T0RFIiwic2VsZWN0ZWROZXJkbGV0Ijp7Im5lcmRsZXRJZCI6ImFwbS1uZXJkbGV0cy5vdmVydmlldyJ9fQ

Screenshot from the APM - this is where I got the App ID from:

Hey @reaanb! I’m sorry for the delay in getting back to you.

I think I’ve finally located the issue!! Because your account is in the European data center, you’ll need to hit the API’s EU endpoint. The API Explorer populates the US endpoint, so you’ll need to copy & paste the cURL command into your terminal when you have it updated with the EU endpoint.

In this case, the endpoint should be https://api.eu.newrelic.com/v2/applications/79942881/deployments.json.

Could you give it another shot, and let me know if it works OK this time around? Again, apologies for the delayed response.

Fingers crossed! :blush:
Maggie

2 Likes

Thank you very much, Maggie!
That resolved my issue.

2 Likes

Glad to hear it, @reaanb! Hope you have a good rest of your week! :smile: