Checking for data in New Relic (this may take a few minutes)...failed

Hi,
Below I added my logs when you can see that I am trying to integrate mysql plugin with new relic. I am trying to integrate mysql plugin in two ways: Guided install and EU Guided install but an error is the same. I run this command on my linux machine:
curl -Ls https://raw.githubusercontent.com/newrelic/newrelic-cli/master/scripts/install.sh | bash && sudo NEW_RELIC_API_KEY=... NEW_RELIC_ACCOUNT_ID=... /usr/local/bin/newrelic install

I am receiving this:

? MySQL Username newrelic
? MySQL Password *************
? MySQL Hostname (default: localhost) localhost
? MySQL port (default: 3306) 3306
? MySQL Database Name database_test
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.quelquesmots.fr
 * epel: d2lzkl7pfhq30w.cloudfront.net
 * extras: centos.mirror.fr.planethoster.net
 * updates: centos.mirror.fr.planethoster.net
Package nri-mysql-1.5.1-1.x86_64 already installed and latest version
Nothing to do
 ❌ Checking for data in New Relic (this may take a few minutes)...failed.
==> Installing mysql-open-source-integration...failed.
WARNING encountered an error while validating receipt of data for mysql-open-source-integration: reached max validation attempts
WARNING execution of MySQL Open Source Integration failed, please see the following link for clues on how to resolve the issue: https://docs.newrelic.com/docs/using-new-relic/cross-product-functions/troubleshooting/not-seeing-data/
 One or more installations failed. Check the install log for more details: /root/.newrelic/newrelic-cli.log
 New Relic installation complete!
 Your data is available at https://one.newrelic.com/redirect/entity/

I have checked and I see that my new relic agent is connected to this ip address and port : 162.247.242.11:443
For US region accounts:

  • 162.247.240.0/22

For EU region accounts:

  • 185.221.84.0/22

Do you have any idea what could be wrong with this step of integration? What can I check to fix this process?

Hi

We need a call to check the issue

Regards
Madan

@lukasz.gackiewicz Looks like you are working with our support team via ticket on this issue. If you need further support in other areas let us know. Thanks :slight_smile:

I’m having the same issue for mysql 8 and apache 2.4 on Ubuntu 20.04 LTS.

MySQL Password:
[OK] All checks passed. Installing MySQL Integration...

Ign:1 http://apt.newrelic.com/debian newrelic InRelease
Hit:2 http://apt.newrelic.com/debian newrelic Release
Hit:3 http://mirrors.linode.com/ubuntu focal InRelease
Hit:4 http://mirrors.linode.com/ubuntu focal-updates InRelease
Hit:5 http://mirrors.linode.com/ubuntu focal-backports InRelease
Hit:6 http://mirrors.linode.com/ubuntu focal-security InRelease
Hit:7 https://download.newrelic.com/infrastructure_agent/linux/apt focal InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
nri-mysql is already the newest version (1.6.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    ❌ Checking for data in New Relic (this may take a few minutes)...failed.
==> Installing mysql-open-source-integration...failed.

WARNING encountered an error while validating receipt of data for mysql-open-source-integration: reached max validation attempts
WARNING execution of MySQL Open Source Integration failed, please see the following link for clues on how to resolve the issue: https://docs.newrelic.com/docs/using-new-relic/cross-product-functions/troubleshooting/not-seeing-data/
  One or more installations failed.  Check the install log for more details: /root/.newrelic/newrelic-cli.log
  New Relic installation complete!
  Your data is available at https://one.newrelic.com/launcher/nr1-core.explorer?platform[filters]=&platform[accountId]=2829597
FATAL We encountered an error during the installation: encountered an error while validating receipt of data for mysql-open-source-integration: reached max validation attempts. If this problem persists please visit the documentation and support page for additional help here: https://one.newrelic.com/-/06vjAeZLKjP
1 Like

Hi @Beorn,

Thank you for your patience and apologies for the delay in getting your question answered. Are you still experiencing this issue? If so, can you confirm that infrastructure agent was installed first?