Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

Cloud Optimizer Nerdpack

new-moderation-topic
mod_queue
sla_breaching
nerdpack

#1

Cloud Optimize Nerdpack :cloud:

Let’s talk dollars and cents! The Cloud Optimization Nerdpack will help you determine potential savings across your environment. :money_mouth_face: It’s your time to really impress your Executives!

Note: This Nerdpack currently only supports AWS.

Be sure you have the following requirements listed below:

To maximize the use of this Nerdpack it is suggested you:

  • Install the EC2 integration for additional metadata to allow for grouping by your Cloud Provider Account
  • Install APM on your applications for grouping by application

Clone This Nerdpack

Clone this repository and run the following scripts:

git clone https://github.com/newrelic/nr1-cloud-optimize.git
cd nr1-cloud-optimize
nr1 nerdpack:uuid -gf
npm install
npm start

Visit https://one.newrelic.com/?nerdpacks=local, navigate to the Nerdpack, and :sparkles:


The full Cloud Optimizer GitHub repository and ReadMe can be found here.

Happy Nerd-ing! :nerd_face:


FutureHack Nerdpack Contest - Win an iPad!
#2

Hi Kav,
I’ve installed the cloud optimizer nerdpack but i can see no data as it shows 0 accounts.
I can tell this line:
const gql = {actor {accounts {name id reportingEventTypes(filter:["${eventType}"])}}}
//eventType = “SystemSample”

returns no accounts although the current account has data and it is showing up correclty on the new relic account.
I’ve tried to direclty hard-code the account id instead of calling the query, but nothing changed.

Regards


#3

Hi @mira.barsoum -

Can you confirm that the API key you have set up in your New Relic One profile (nr1 profiles:list) matches that of the account you have data flowing to?


#4

I am getting the same thing here.
Trying to get cloud optimizer running locally, and I am just seeing “Unable to load accounts!” when I view my local running instance in NR1.

If I run nr1 profiles:list I get :
Name Region API key
my-account us
default us

So it looks like it is there.
Any ideas?


#5

I managed to publish and deploy cloud optimizer, and I can see the data appearing now!
So it would appear that the issue is only when running locally.

I also had to generate a new UUID to get it to publish. I was getting errors like -
Error: The Nerdpack you are trying to publish was created on a different account.

I also had to add myself as a Newrdpack manager, which I was not aware of!


#6

Hey @brett.howells -

I’m not sure why you’d see that issue when running locally. It’s a little odd, I’ll try run cloud optimizer locally here and follow up with what I learn.


Another note is that UUIDs are tied to the API key of the user who created them. Nerdpacks are published against those UUIDs. When you publish, we’ll check that the UUID correlates to that of the API key you are using to publish.

So it is always recommended that as soon as you clone a nerdpack you should run:

nr1 nerdpack:uuid -gf

Which will create a new UUID with using the CLI profile tied to your API key.

If you grab the nerdpack by using:

nr1 nerdpack:clone -r https://URL.git

Then it will automatically update the UUID once the clone operation is complete.


Finally, yes, nerdpack manager is a requirement for deploying nerdpacks, unless you are an account Owner, where that nerdpack manager entitlement is automatically applied.

This is documented here in the New Relic One Applications Requirements doc:
https://docs.newrelic.com/docs/new-relic-one/use-new-relic-one/build-new-relic-one/new-relic-one-applications-requirements-security#security


#7

Hey Brett -

Just finished my test - while serving locally I was able to see cloud optimise data (though numbers & details obfuscated):


#8

So, who has deployed this and found good money to save? What and how did you find it?