Compatibility with Oracle Database driver on supported version of Java

I see that currently the Oracle JDBC driver for Java 7 is supported, but Oracle JDBC driver for Java 8 (ojdbc8), which is years old, and the Oracle JDBC driver for Oracle Database 18c (ojdbc18.3), which is new, is not currently supported. As Java 7 is no longer supported by Oracle, even though New Relic is compatible with ojdbc7 and Java 7 nobody should be using this if they have a choice. Therefore as none of the Oracle JDBC drivers are actually compatible in the current Java Agent release on any support version of Java, could the recently Oracle drivers please be investigated for compatibility?

  • I want this, too
  • I have more info to share (reply below)
  • I have a solution for this

0 voters


New Relic Edit
We take feature ideas seriously and our product managers review every one when plotting their roadmaps. However, there is no guarantee this feature will be implemented. This post ensures the idea is put on the table and discussed though. So please vote and share your extra details with our team.

Hey @Trevor_Dearham Thanks for posting your feature idea here, and thanks for adding the poll so we don’t have to :smiley: - I have gone ahead filing this as a feature request internally on your behalf too.

2 Likes