Configuring data ingesting

Hello!

I want to tweak my data ingestion parameters to be in 100 GB free range.

I’ve tweaked infrastructure and processes, but biggest impact on data volume is made by “tracing” and “metrics”.

Although I’ve turned tracing off via newrelic.transaction_tracer.enabled = false, chars still showing ~4 GB per day.
Transactions → Traces list was empty.

As for “metrics”, I couldn’t find any config values to tweak it’s ingest rate.

Can someone please point me:

  • how to see exactly what data do I ingest (not abstract “traces”, but exactly what traces);
  • how to tweak this “traces” (I’ve been sure newrelic.transaction_tracer.enabled = false is enought to turn them off?) and “metrics” ingestion rates?

Thank you.

Hi @lglss

Thanks for reaching out, I hope you are well.

Congrats on your first post in the community, Whoop!

I have located a doc and a post that should be of great use here. They guide users how with resources on how to manage data ingest.

I hope this was helpful, should you have any questions or updates please do reach out.

Also if this helped resolve the issue please consider selecting the Solution ( How to Use the Official Solution Checkbox )option below this post.

Hello and sorry for slow answer.

I’ve used code from post you linked, and I see most data is comming from newrelic.goldenmetrics.browser.* metrics.

As I can see from docs, the only way I can lower ingest rate - is by setting a drop rule, right?

Hi @lglss

Thanks for reaching back out. Im glad the previous docs I linked were helpful.

I have gone ahead and located another doc on Drop rule filters, please see here. Unfortunately in support we don’t traditionally support data ingest unless there is a noted issue or bug with the process, so my insight may be slightly limited here.

I hope this was helpful, should you have any questions or updates please do reach out.