CPU Information Displaying incorrectly 1 CPU when i have 2

on the server overview page it states that i have 1 CPUs when i actually have 2 CPUs.
I have my server in the cloud and i have just added another CPU to my server but the has not populated through to new relic. How do i fix this?

Linux 2.6.32-531.11.2.lve1.2.55.el6.x86_64 x86_64
New Relic agent 1.4.3.478

Cloudlinux Cpanel server

@jloeken this may relate to the other issue you reported in https://discuss.newrelic.com/t/servers-processes-only-displaying-nrsysmond-and-nothing-else/

Running as an unprivileged user, nrsysmond won’t be able to gather very much information from your system.

Did you recently upgrade the number of cores in your system?

Also, the server monitor will only read your environment on startup, it doesn’t recheck these values.
This means if you add or remove resources, we will not see it.

Restarting the server monitor should resolve this issue for you.

how do i restart the server monitor?

I have run this from the command line:

/etc/init.d/newrelic-sysmond restart

The number of CPU cores was not updated.

Yes, i upgraded server about a month ago,

Re: security issue in other post. I do not know how to find security application or even if /proc/ folder is protected. but i have updated the other post regarding this.

Hi @jloeken! What you describe is similar to some other reports that we’ve seen. I am going to start a support ticket with you to go through the details. We will follow up on the forum at the ticket’s conclusion.

OK … So here is the solution… and steps to try from the support team.
as of today there is still a bug where if you have a cloud server and you update the amount of virtual CPUs on your server this information will not flow through to the RPM newrelic website. Below are the steps i followed to fix the issue and update the number of CPUs in the RPM.

The third option worked but Not a very good solution. To have to remover the server and all historical logs from the newrelic RPM website… :frowning:

Tried stopping service for 10 minuts… —> Did not fix CPU count on RPM

  /etc/init.d/newrelic-sysmond stop
 /etc/init.d/newrelic-sysmond start

Tried stopping and uninstalling newrelic from my server then reinstalling. —> Did not fix CPU count on RPM

 /etc/init.d/newrelic-sysmond stop
 yum remove newrelic-sysmond
 yum install newrelic-sysmond
 /etc/init.d/newrelic-sysmond start

Tried stopping service uninstalling wait 10 minuts, Delete server from RPM Servers (newrelic website) reinstall, set licence key, start. —> Fixed Issue but at a cost of losing all historical data… :frowning:

–Stop newrelic service
–Remove Newrelic installation

   /etc/init.d/newrelic-sysmond stop
   yum remove newrelic-sysmond

-Wait 10 minuts for RPM newrelic to giv you the option to remove server from site.
–Remove server from newrelic website RPM
–Then reinstall newrelic on the your server

 yum install newrelic-sysmond

–add licence key back to the /etc/newrelic/nrsysmond.cfg

 nrsysmond-config --set license_key=YOUR_LICENSE_KEY

Optional: You can set the license_key configuration setting directly in/etc/newrelic/nrsysmond.cfg instead.

–Start the newrelic service

 /etc/init.d/newrelic-sysmond start
1 Like

Hi @jloeken - I have reported this to the team and am working with them on it. We definitely don’t want you to have to suffer data loss to fix an issue. Thank you for taking the time to document so thoroughly the steps you’ve taken and what was needed to move forward.

I am also experiencing the same problem.

OS is oracle Enterprise Linux 6

increased a VM from 8 cores to 12 cores and still reports 8. the CPU % is reporting correctly.

We do not wish to lose the data as we are comparing before/after CPU core increase but the incorrect reporting is confusing users

Hi @Galballyj,

Our only currently known workaround is as mentioned by @jloeken which does indeed cause historical data to be lost.

We do have an open report on this issue and are working towards a fix. Currently there is no ETA. Apologies for the delay.

Has there been any progress on this issue in the last six months?

Not to my knowledge.

1 Like

it would be lovely to have progress on this, even if there was just a manual way to enforce refreshed system specs

Hi @Bulletproof,

We have no update to share at this time.

The only workaround is to report the server as a new instance. Either by changing its name or deleting the current instance.
https://docs.newrelic.com/docs/servers/new-relic-servers-linux/troubleshooting/servers-linux-known-issues#static-environment

Sadly that removes all historical data, retention of which is one of the main reasons for customers to pay for Pro subscriptions. If you do come up with an alternate solution please let me know as we have clients who would love to have this implemented without losing recorded metrics.

1 Like

Very good points @Bulletproof. We will update this thread when we have updates related to the issue.

1 Like

Hello,
We have the same issue. Has this been adressed yet or is there a workaround where you don’t loose your data? This was reported more than a year ago…

Hey @helena.aberg.ostlund—No official fix yet. Thanks for being patient while we all wait for an update on this.

I will definitely pass your input up to my product managers so they can see how this is affecting you. Thanks so much, and keep an eye on this thread for any future updates!

Hi Linds,

Any updates regarding this issue? We still have clients who are enquiring about this and they are disappointed when we advise them that the only solution is compromise. Perhaps a manual method where metrics can be re-attached to the newly re-added host, which is currently presented as the best workaround?

Kind Regards,
Joel Devlin
Bulletproof Networks

As of right now, I only have the workaround to offer @Bulletproof! I will update this thread as soon as I hear news on an official fix. Thanks for your patience!