Creating a custom table but not seeing the data

Hi, I am using the insight key to enter the custom attribute in a table but I am not seeing the data in the table. I was able to see the table and the data until last week, but it has stopped working now.

I am sending a post command to with the below JSON. I also added the insight key as a header.
“account_id”: “3434”,
“timestamp”: “4234”

Hi @amit.tarneja1

I’m curious how your JSON formatting has changed recently?

I ran a query in your account to see errors in sending data:

SELECT * FROM NrIntegrationError WHERE newRelicFeature = 'Event API' SINCE 2 weeks ago limit MAX 

I am seeing a result:

JSON couldn’t be parsed because it’s syntactically invalid

Could you change your JSON to include [ ], and see if that helps?

      “account_id”: 3434,
      “timestamp”: 4234

I tried the json shared by you, but still no luck. Apparently, I tried verifying the JSON on the jsonlint website and it says that the JSON is invalid. I tried a few different options and only got an error once in
the NRintegrationError for all my tries. Also, for all the requests that I am sending to the API is returning 200 and with a UUID.

Hey @amit.tarneja1

I think I see the issue… I copied the JSON into Visual Studio Code & it highlighted the error being that the " " aren’t actually formatted correctly.

I don’t know how this happens. I don’t know another way to type " " on my keyboard, but, somehow between copy pasting these were malformed.

So I updated those to the right " " (the right being those that I can type on my keyboard).

And I sent the data and the JSON was now valid, but the events weren’t showing up.

And then I realised, previously I had thought that the example data you sent was just that, an example, not the real data. But in case you are actually using that data sample, there is a problem.

Timestamp is a attribute set by default when the events are sent. You can overwrite it in your JSON payload, but you can only overwrite it with a timestamp within 24hrs of the current point in time.

If you are sending 4234 as a timestmap, that is translated to January 1, 1970 1:10:34 AM from Epoch time (ms since 1/1/1970 00:00:00)

So that’s not an acceptable timestamp. And if it was, we would need to query:


Which of course won’t work.

So I changed the attribute name to myTimestamp instead of timestamp, and this solved it. The events are coming into my account:

Hope this helps!


thanks a ton, it did help.

Great! Glad that was helpful - thanks for letting us know :slight_smile:

A post was split to a new topic: Error creating custom event