Data not reflecting on NewRelic-Infra dashboard

I have installed NewRelic-Infra on a rhel6 server. The problem is after successfully installing, it did not reflect on the dashboard. so i ran newrelic-infra on its root directory. problem is SELinux wasnt able to contunie it. I suspect maybe it was affected by the first installation i did. I accidentally installed rhel 7 version of newrelic but removed it afterwards and installed the right version. however, it still did not work. i’m wondering what are installed files and configs during the installarion of rhel7 version that should be rolled back.

Hey there @icon0428! Welcome to the Explorers Hub!

I just want to make sure that I am understanding you correctly. If I do, you are unable to successfully install the RHEL6 version of the Infrastructure agent after mistakenly installing the RHEL7 version. Can you confirm how you removed the RHEL7 version? We have uninstall information available in our documentation.

nope, it was actually completed. the problem is, it is not showing on the list of hosts on newrelic-infra’s dashboard.

Gotcha! Thank you for clarifying, and sorry I got that wrong.

For the missing hosts please run through the following steps and let me know what your findings are:

  • Verify that your newrelic-infra.yml configuration file contains a valid license_key setting.

  • Verify that the host has a unique hostname, and verify that the hostname is not localhost. For more information, see this Community post.

  • Verify that no firewalls or proxies are blocking outbound connections from the agent process to the Infrastructure domains and ports.

  • Confirm the host is reporting correctly even though it is not appearing in the Infrastructure UI by creating a basic query in Insights, like:

SELECT * FROM SystemSample SINCE 60 minutes ago LIMIT 100

  • Use the query results to note the timestamps, which show when the data was reported. To determine when data was first received, look at the earliest timestamp.

(or let me know if you have been through any of these steps!)

after executing this command - yum remove newrelic-infra for the wrong version i installed and it was removed successfully. Next is installing rhel6 version, it was also successful. The problem that i see is, the monitoring wasn’t running. as I tried the command - (initctl status newrelic-infra) it says the job was unknown. As i tried to start the job manually by accessing it to /usr/bin/newrelic-infra, it actually start showing to the dashboard but exiting the command also shutsdown the service.

[root…]# /usr/bin/newrelic-infra
INFO[0000] New Relic Infrastructure Agent version 1.0.898 Creating Service (1.2556ms)
INFO[0000] Agent service manager started successfully. (1.3774ms) service=newrelic-infra
INFO[0000] New Relic Infrastructure Agent version 1.0.898 Initializing (1.6494ms)
INFO[0000] New Relic Infrastructure Agent version 1.0.898 Running (305.152801ms)
WARN[0000] unable to use SELinux error=SELinux status: disabled

^C2018/05/04 17:08:50 Orderly shutdown commenced
INFO[0130] Gracefully Exiting
INFO[0130] Agent service manager shutdown completed successfully. service=newrelic-infra

just for clarification, installing rhel7 and removing it has no effect for this issue? :slight_smile:

Hi there,

so it appears that you can’t start the agent via initctl, but can manually through /usr/bin/newrelic-infra. If that is the case, then I believe your repo cache is probably “holding” onto the rhel7 repo information. I would do the following:

Please let us know how it goes.

1 Like