Delete APM services from New Relic One

We wanted to delete previously configured Services in APM from the newrelic one UI. But couldn’t find the settings

On the other hand, new API are not getting registered even after making changes in config file.

Windows Server and .Net non web applications (.exe)

Do we need to restart any windows service apart from iisreset. If so, please share

Can someone suggest on this. Thanks in advance!

Hello @agodavarthi,

Thanks for writing in!

If you previously configured APM application that reported to New Relic, the first and most important step is to make sure that, the application in question stops reporting data. You can do this by disabling the agent or removing the agent completely.

In NR1 there isn’t yet an option to remove the app via UI but if the application is inactive it will be automatically removed after 93 days. As an alternative, you can remove the application that hasn’t been reporting for minimum of 12 hours using our REST API. Please have a look into the document below which discusses app removal in more detail:

https://docs.newrelic.com/docs/apm/new-relic-apm/maintenance/remove-applications-new-relic

Removed the agent from Windows , but of no luck.
And on top of that , now I’m not able to create new applications , they stopped getting registered .

Removing the agent didn’t work here. As mentioned earlier , not able to add new applications as well

Here is the diagnostic report . Please resolve , as we need to decide if this tool helps us or not.

Check Results

Info Base/Env/CollectEnvVars [Gathered Environment variables of current shell.]
Success Base/Config/Collect
Error Base/Config/Validate
Success Base/Log/Copy
Info DotNet/Env/Versions [2.0.50727, 3.0, 3.5, 4, 4.0, 4.7 or later]
Success DotNetCore/Agent/Installed
Failure DotNetCore/Config/Agent
Info DotNetCore/Env/Versions [2.2.102]
Success Base/Env/CheckWindowsAdmin
Warning Base/Config/LicenseKey
Warning Base/Env/HostInfo
Success DotNetCore/Requirements/OS
Success Java/JVM/VendorsVersions
Success DotNetCore/Requirements/DotNetCoreVersion
Success Base/Collector/ConnectUS
Info Base/Env/IisCheck [Version 10.0]
Error Android/Agent/Detect
Success DotNetCore/Requirements/ProcessorType
Success Base/Collector/ConnectEU
83 results not shown: 83 None
See nrdiag-output.json for full results.

Issues Found

Error - Base/Config/Validate
Task did not meet requirements necessary to run: type assertion failure

Failure - DotNetCore/Config/Agent
Unable to validate the .NET Core agent config files.

Warning - Base/Config/LicenseKey
No New Relic licenses keys were found. Please ensure a license key is set in your New Relic agent configuration or environment.
See https://docs.newrelic.com/docs/using-new-relic/cross-product-functions/install-configure/configure-agent for more information.

Warning - Base/Env/HostInfo
Error collecting complete host information:
context deadline exceeded

Error - Android/Agent/Detect
Error occurred reading the Base/Config/Collect payload

To diagnose a specific product or issue, see task suites options: ‘C:\Users\agodavarthi\Downloads\nrdiag_latest\nrdiag\win\nrdiag_x64.exe -h suites’

Hey @agodavarthi - You should not have any problems creating new apps. I’m going to DM you on this.

Did you get this to work? I have 2 dummy services that were created at the initial setup. And no data since early October. So if 93 days is true i should see them disappear next month.

But interested if you were able to add new applications after you removed the agent with the REST API.

tks

Hi @Craig.Tarr, if you’re running into an issue like this, try running our NR Diagnostics tool in the ticket, which will check some of the basic settings and environment details of the system and grab logs to get some insight in to what you’re seeing.

You can download the latest version of the tool here.

Once you have downloaded it, please:

  1. Unzip the file to any location.
  2. Open an elevated command prompt at that location.

Let me know how that goes for you.

Thanks @nmcnamara for the follow-up.

I’ll run the NR Diags to a support ticket and post an update once I have one.

What I see on my side in the UI is no option to simply delete. When I go into the Service there’s no data and still no option to delete.

Hi, @Craig.Tarr: You may find this post helpful:

2 Likes

Wanted to follow-up on this thread for anyone asking the question about wanting/how-to to remove Applications from the UI. I can confirm as the articles and discussions state, that after 90 days of inactivity the Applications are automagically removed. I didn’t do anything programmatically, I just let them fall off.

So now I only see the active applications in my dashboards. HTH.

1 Like

When will the ‘Delete App’ button be available in the NR1 UI?