Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

Disable Jedis Custom Instrumentation

new-moderation-topic
mod_queue

#1

Hi All,

We are trying to disable the Jedis auto-instrumentation data from being sent to New Relic in favor of manual custom tracing. We are using a jedis fork originally from Jedis version 2.2.0 and we tried disabling that version after class_transformer: in newrelic.yml. This did not stop the reporting as we had hoped. Do we have to add in com.newrelic.instrumentation-jedis.X.X.X: false for all versions of Jedis to achieve the desired result?

Thanks!


#2

Hey @brendan.jones1 - Our instrumentation versions are a little tricky, we don’t have one for each version but the ones we do have are versioned based off of the earliest version that instrumentation will get applied to. For example these are our current Jedis instrumentation modules:

com.newrelic.instrumentation.jedis-1.4.0
com.newrelic.instrumentation.jedis-2.7.1
com.newrelic.instrumentation.jedis-2.7.2

In this case, since you are using a fork of 2.2.0, the instrumentation most likely getting used for your application is the com.newrelic.instrumentation.jedis-1.4.0 module(which should get applied to any version from 1.4.0 to 2.7.1 exclusively, at which point the next module would be used instead). It appears you’ve already figured this next part out but for the sake of clarity, you’d want to add the following lines inside of the class_transformer: stanza of the newrelic.yml file to disable the instrumentation:

    com.newrelic.instrumentation.jedis-1.4.0:
      enabled: false

Let us know if that works out for you! If not, feel free to share a link to the application in New Relic and I can take a closer look at the instrumentation modules that are being applied. The only other thing worth noting is that some of our generic Java instrumentation (such as JDBC or HTTP instrumentation) may also be getting applied on top of the Jedis-specific modules.


#3

Hi @MrMatt,
Thank you for your reply! Interesting enough, we were able to go into the logs and turn them up to finest and see which instrumentation were being used and saw that all 3 of those were being checked. We added the logic to disable all 3 and it worked. Thank you for your help and quick reply!