Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

Dot Net Agent Compatibility pre-4.5 Framework vs. 4.5+


#1

We have some deployments running in older DotNet Frameworks (pre-4.5), as well as other deployments with newer DotNet Framework versions. Although not always having been the case, all of our servers now have newer versions of DotNet Framework installed, including those running applications completely written in older Frameworks.

My question is: Considering the removal of support for pre-4.5 Frameworks as of the 7.0.2.0 Agent, are our servers that are running the pre-4.5 Framework applications restricted to using the DotNet Agent 6.22.0.0 or previous (because the applications are running older frameworks), or would they be free to use the latest DotNet Agents (because the latest DotNet Frameworks are installed on the machine)? Or is this question more complicated than a simple answer would allow?

I realize that the original statement on this posted a year ago says:

Apps compiled for CLR2 but running on .NET Framework 4.5 may run into issues.

But after a year, I’m hoping that perhaps the “may run into issues” has been proven to be a conservative statement, with little-to-no issues actually occurring.


#2

Yes also have some applications running on old .net framework, till now we haven’t face any issue yet.
Only thing is, these server misses out on the new features & fixes which NewRelic releases like distributed tracing…

Many Thanks
Umesh


#3

Hi there,

I would recommend using the 6.22 agent when instrumenting pre-4.5 Framework applications. This is because even if you have installed the latest .NET Frameworks on the machine, your app may still be targeting a pre-4.5 version (usually specified in a web.config), and our 7.x and 8.x agents will likely not even load into the app’s process because it will recognize that it’s an unsupported framework.

Regarding apps being compiled for CLR2, depending on your app code you might be able to configure it to run on 4.5, but I’m not too familiar with that process.

Cheers,
Neil