Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

Duplicate Application Name after deployment

apm

#1

After completing a website deployment I see duplicate names of Application and the data is updating on 1 of them. The web application is only on 1 server so I’m sure what is going on.


#2

hey @jason.ford

Could you tell us what type of Agent you are running this application on? Is it dotNet, PHP etc? Would it be possible for you to provide me with a permalink?

You can do this by navigating to the page where the issue is present, scrolling down to the bottom right corner and clicking on ‘Permalink’. This should provide you with a URL you can send back to us so we can investigate further.

Speak soon!


#3

Its a .net application
https://rpm.newrelic.com/accounts/868655/applications


#4

https://rpm.newrelic.com/accounts/868655/applications, its a .net application


#5

Hey!

So it looks like you have one reporting and one not reporting. Do you perhaps have other copies or builds of that app also reporting on that machine?


#6

I have the same error but with the php agent.
I already change the newrelic.ini “appname” but i still got the duplicate name.

Any suggestion?


#7

Nelson,
Can you provide a Permalink for us to look at? And the name of the application that is being duplicated?

Also, did you restart your webserver after the change? INI file changes are only active after a restart.


#8

Did you get anywhere with a solution for this? I have the same problem where I have a .NET application which there are now 2 New Relic applications with the same name but different IDs, one reporting and one not. The one not reporting was the only application until Friday evening, and now we have this second one which has taken over and is now receiving data leaving the original application unused.
Friday evening we called the API to create a deployment marker for the application, and this has happened at the same time. I have a number of other websites which the same deployment marker code has been run for and this duplication has not happened to them.
Thank you.


#9

Hi @johncorker,

Can you give us links to the apps in question so we can take a look?


#10

Hi @hwilkalis,
Apologies for the delay, I didn’t get a notification for your reply and just checked back to make sure there was no update!
Original app was: https://rpm.newrelic.com/accounts/773510/applications/6211661
This changed on our first deployment marker being created to: https://rpm.newrelic.com/accounts/773510/applications/394964930
I have changed the app name to blank when I posted this, thinking it would stop reporting until we had a fix but this is reporting to a blank app name currently:
https://rpm.newrelic.com/accounts/773510/applications/398178296

Thank you for your help.
John


#11

@johncorker -

I think I know what happened.

But first, I would recommend not using the “alias” naming feature. It can create confusion. If you look here, you’ll see the agent configured name - that’s the “Your application still reports as…” name.

If you look here you’ll see the configured name looks to be white space (which is not recommended either :slight_smile: )

It looks like someone changed the agent configured name to match the original UI alias name which created a duplicate name entry (one of the duplicates was the alias and the other was agent configured). See https://rpm.newrelic.com/accounts/773510/applications/394964930/settings-application and compare to https://rpm.newrelic.com/accounts/773510/applications/6211661/settings-application

I would recommend:

  1. Don’t use the UI alias feature (the name there should match the agent configured name).
  2. Make sure the agent configured name is what you want it to be across all app instances.
  3. Here is a .NET doc on naming applications: https://docs.newrelic.com/docs/agents/net-agent/configuration/name-your-net-application
  4. You should be able to change the agent configured name back to the original one and have things report back to the original name.

Does that make sense?


#12

Spot on, thank you. I think the alias was added for this website when the domain name changed a couple of years ago, so it was long gone in our memories that it had an alias. This explains why the other websites worked fine as they don’t have an alias.

Thank you for looking into this.


#13

Good to hear Ted was able to help you out with this! Let us know if you have any further questions. :smiley: