End of life Notice: New Relic Agent Support for Node 8

What is happening?

After October 31st, 2020, we will no longer support Node.js 8 for new versions of our agent, but we will offer support for Node.js 14.

Why?

The maintenance cycle for Node.js 8 ended in December 2019, meaning there have not been updates, bug fixes or security patches since then. We encourage customers to upgrade to supported versions of Node and the latest version of the New Relic Node agent to take advantage of the newest Node Agent features.

What do I need to do?

We recommend that you upgrade your version of Node.js as well as upgrade your agent to the latest version to ensure that you can take advantage of new features. However, you may continue using Node.js 8 by staying on the last version of the agent that supported Node.js 8.