Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

ERROR : Invalid license key

rails
errors
license-key

#1

https://rpm.newrelic.com/accounts/2188107

ruby 2.2.4p230 (2015-12-16 revision 53155) [x86_64-linux]
rails 4.2
newrelic_rpm 5.5.0.348

-Both NEWRELIC_LICENSE_KEY and NEWRELIC_APP_NAME ENV variables are set
-newrelic.yml file downloaded from New Relic UI page

LOG:

[2018-12-11 17:55:04 +0100 (6351)] INFO : Starting the New Relic agent version 5.5.0.348 in “development” environment.
[2018-12-11 17:55:04 +0100 (6351)] INFO : To prevent agent startup add a NEW_RELIC_AGENT_ENABLED=false environment variable or modify the “development” section of your newrelic.yml.
[2018-12-11 17:55:04 +0100 (6351)] INFO : Reading configuration from config/newrelic.yml …
[2018-12-11 17:55:04 +0100 (6351)] ERROR : Failed to read or parse configuration file at config/newrelic.yml
[2018-12-11 17:55:04 +0100 (6351)] ERROR : Psych::SyntaxError: (): found unknown escape character while parsing a quoted scalar at line 27 column 24
[2018-12-11 17:55:04 +0100 (6351)] ERROR : No application name configured.
[2018-12-11 17:55:04 +0100 (6351)] ERROR : The Agent cannot start without at least one. Please check your
[2018-12-11 17:55:04 +0100 (6351)] ERROR : newrelic.yml and ensure that it is valid and has at least one
[2018-12-11 17:55:04 +0100 (6351)] ERROR : value set for app_name in the development
[2018-12-11 17:55:04 +0100 (6351)] ERROR : environment.
[2018-12-11 17:55:04 +0100 (6351)] INFO : Installing Net instrumentation
[2018-12-11 17:55:04 +0100 (6351)] INFO : Installing deferred Rack::Builder instrumentation
[2018-12-11 17:55:04 +0100 (6351)] INFO : Installing Rack::Builder middleware instrumentation
[2018-12-11 17:55:04 +0100 (6351)] INFO : Installing deferred Puma::Rack::Builder instrumentation
[2018-12-11 17:55:04 +0100 (6351)] INFO : Installing Puma::Rack::Builder middleware instrumentation
[2018-12-11 17:55:04 +0100 (6351)] INFO : Installing Rails 3+ middleware instrumentation
[2018-12-11 17:55:04 +0100 (6351)] INFO : Installing Sidekiq instrumentation
[2018-12-11 17:55:04 +0100 (6351)] INFO : Installing ActiveRecord 4 instrumentation
[2018-12-11 17:55:04 +0100 (6351)] INFO : Installing ActiveJob instrumentation
[2018-12-11 17:55:04 +0100 (6351)] INFO : Installing Redis Instrumentation
[2018-12-11 17:55:04 +0100 (6351)] INFO : Installing Rails 4 Controller instrumentation
[2018-12-11 17:55:04 +0100 (6351)] INFO : Installing Rails 4 view instrumentation
[2018-12-11 17:55:04 +0100 (6351)] INFO : Finished instrumentation
[2018-12-11 17:55:04 +0100 (6351)] INFO : Doing deferred dependency-detection before Rack startup
[2018-12-11 17:55:23 +0100 (6351)] ERROR : Invalid license key, please contact support@newrelic.com
[2018-12-11 17:55:23 +0100 (6351)] ERROR : Visit NewRelic.com to obtain a valid license key, or to upgrade your account.


#2

The issue was resolved by fixing a conflict in ENV variables.


#3

Hey @122f6de728aba67e64bb

Thanks for confirming your fix for this :smiley: