Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

Error on a bunch of our servers


#1

We just had a bunch of our servers go dark for server monitoring and APM. I see this in the logs on one of them:

2017-10-16 13:03:01.803 (26897) info: New Relic 2.3.0 (build 132 - “cloudy” - “8cff29599e1e9619b31da739b2ac86c7213f6b71”) [workers=1 pid=26897 ppid=26896 uid=101 euid=101 gid=103 egid=103 backtrace=yes startup=init os=‘Linux’ rel=‘2.6.18-408.el5’ mach=‘x86_64’ ver=’#1 SMP Tue Jan 19 09’ node=‘servername’]
2017-10-16 13:03:04.320 (26897) info: cmd=‘connect’ for ‘Infrastructure’ returned exception type=‘RuntimeError’ message=‘Server Error (Database Error)’
2017-10-16 13:03:04.321 (26897) warning: error connecting app=‘Infrastructure’ rv=4. Retry after delay.

It just keeps retrying but not able to recover. It’s not all of our servers, but it’s many of them.


#2

@mattPresto we are seeing the same error. We have opened a ticket and were directed here. We are trying to raise the issue further on the ticket chain.


#3

Roger that. Glad to see I’m not going crazy. I’ll follow here and have also raised a ticket with support. Will update if I learn anything.


#4

Also seeing the same issue.

Confirmed connectivity to collector.newrelic.com.


#5

Having the same issue as well, verbose log entries below:

verbosedebug: connecting app=‘Infrastructure’
verbosedebug: RPM called with cmd=‘connect’ for app=‘Infrastructure’ license=’…’
verbosedebug: RPM app=‘Infrastructure’ cmd=‘connect’ len=802 json=’[{…}]’
verbosedebug: POST length=404 deflate=1
verbosedebug: RPM url=‘https://collector-…newrelic.com/agent_listener/invoke_raw_method?marshal_format=json&license_key=…&protocol_version=12&method=connect’
debug: RPM cmd=‘connect’ for ‘Infrastructure’ returned code=200
verbosedebug: RPM reply to cmd=‘connect’ for ‘Infrastructure’: {“exception”:{“error_type”:“RuntimeError”,“message”:“Server Error (Database Error)”}}
info: cmd=‘connect’ for ‘Infrastructure’ returned exception type=‘RuntimeError’ message=‘Server Error (Database Error)’


#6

+1

Getting this in both the ruby agent and system monitor.


#7

We are experiencing the same issue. Would be nice to get some feedback from New Relic, or if they would at least update their status page…


#8

Heads up all that NR is looking into this now


#9

Yup, got a response on the support ticket:

Hey Matt,
Thanks for reaching out to support and I appreciate you bringing this up to our attention. We are currently working on resolving this, however, as we have moved all the communication and support for Servers to our online community I would suggest you look for updates on the community post you created.
Please stay tuned and we will send out a public update shortly. Meanwhile please feel free to reach out to us if you have any further questions.
Best,
Nader Allen Mortazavi
Business Support Engineer
New Relic


#10

Hi there everyone,

As of 19:35 UTC your agents should be able to connect to New Relic.

Between 16:17-19:35 UTC your agents may have been unable to connect. For those impacted applications, charts will show gaps in data until the time that the agents reconnected and data collection resumed.

Please verify that all of your agents are reporting correctly. You may need to manually restart your application.

I’ll go ahead and mark this ticket as closed; if after the agent restart you continue to see issues, please let us know and we will continue to troubleshoot your particular case.

Thank you for your patience as we worked through this issue.


#11