Feature Idea: Grails 3 support

Feature Request:
Please incorporate Grails 3.x support in the java agent. The current support for Grails 1.x and 2.x is good but there are a number of customers that would like 3.x support.

There is an issue with screenshots with what a grails 3.x app looks like for reference.
grails-core Issue # 9886

Grails 3 is a framework that utilizes Spring Boot and Groovy.


New Relic edit

  • I want this, too
  • I have more info to share (reply below)
  • I have a solution for this

0 voters

We take feature ideas seriously and our product managers review every one when plotting their roadmaps. However, there is no guarantee this feature will be implemented. This post ensures the idea is put on the table and discussed though. So please vote and share your extra details with our team.

3 Likes

We are facing this exact problem at Bluestem Brands. I will link support tickets we have logged to try and resolve this.

1 Like

Hey @colin.harrington and @Christian.Oestreich

As you mentioned, we don’t currently have support for Grails 3.0 and we appreciate you both voicing your interest! I’ve made sure to open 2 new feature requests on your behalves and forwarded these requests to our product management team.

While we don’t have any guarantee or an ETA on Grails 3.0 support, your +1s help prioritize our future enhancements.

Thanks again for helping us improve!

Thanks @netheroth , that would be great.

FYI, there is a Grails plugin to add Newrelic support to Grails3 app:

So complete support from NewRelic would be fantastic.

1 Like

This is a big deal for us too.

1 Like

Thanks for letting me know, @jpalmer! I will file a feature request on your behalf right now! :thumbsup:

+1
I’m currently migrating to Grails 3 and better New Relic support would be very welcome.

1 Like

Excellent, @goeh! I will be sure to create a feature request for you so my product managers know how this will benefit you! Thanks for your +1!

+1 for complete support from NewRelic.

1 Like

Thanks @donbeave! I just filed a feature request for you. :heavy_check_mark:

2 Likes

Grails 3 support would be most welcomed for us too!!!

1 Like

Awesome, @sergio.delamo! I will file a feature request for you as well! Thanks for adding your voice. :thumbsup:

1 Like

Add me to the list of people requesting better Grails 3 support!

2 Likes

You got it, @gsAndrew! Be sure to add your vote above as well! :blush:

add me to please, lack of grails 3 support is becoming a blocker to me staying a newrelic customer

1 Like

Hey guys, any news on Grails 3 support?

Grails 2.x was the peak of it’s popularity. Supporting Spring-boot is the better solution as Grails 3 has had a severe drop in community, jobs and uptake (see linkedin.com/pulse/how-spring-boot-killed-grails-owen-rubel )

Are you suggesting just ignore big community just because of google trends? There are a lof of companies who are using Grails 3, like Target for example.

1 Like

I don’t believe I quoted Google trends. But if you look at all market trends, Grails statistics have fallen to 2009 levels of popularity AND USAGE. While there are some companies that do use Grails, supporting Springboot is more than enough to supply that level of support through to child projects like Grails. But Springboot has far more momentum and support and it would be better for them to support that project and hence support Grails through that.

+1 to Grails 3 support

1 Like