GCP Integration not reporting metrics of project's infrastructure

Hi,

I’m trying to set up a 3rd GCP project integration in new relic, have followed the steps exactly, and have the project showing in new relic. However, when I try to view the dashboard for one of the resources, for example Cloud SQL, I only see 1 entry ‘GcpCloudSqlSample’. It’s not picking up my actual Cloud SQL instance that I have running in the project.

I’m 100% sure I’ve added the correct service account email and permissions since new relic is able to find and link the project. I’ve ensured that Stackdriver Cloud Monitoring API is enabled and I’ve tried to unlink and relink the project to new relic to no avail.

Is there something I’m missing here? The other 2 projects I have set up on new relic with the GCP integration are working fine and reporting all data I’d expect.

Thanks,
Dean

1 Like

I’m having the same issue.


UPDATE 2

I tried giving the NewRelic Service Account the permission “Service Usage Consumer” and now it works!


UPDATE

After some further digging I did have a permission problem. NewRelic complains that the service account lacks the permission service.usage.use even though I’ve given it the roles described below. I can’t find any information about service.usage.use though :man_shrugging:


I’ve

  • Tried to give the NewRelic service account the Monitoring Viewer permission (already gave it Viewer), but unfortunately that didn’t seem to make any difference.
  • Made sure there are no API auth errors
  • Waited a few hours

In the NewRelic docs it says that it need “Project Viewer”, but in GCP it looks like that is called “Viewer” now… (under Basic > Viewer, see attached screenshot).

Documentation that I’ve read/followed/checked

2 Likes

Glad to hear you got it working.

My issue was that I had added ‘Service Usage Viewer’ rather than ‘Service Usage Consumer’. Once I swapped them out it worked perfectly.