Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

Getting error: unable to open '' when running app in XCode 10.1


#1

Hi,

We are getting following error when running our iOS application in XCode 10.1 version.
error: unable to open ''

Below are details -

What agent version are you using? (click to see release notes)?

  • New Relic Agent Version: 6.4.1

Please share which platform you have questions about: iOS, Android or hybrid?

  • iOS

Are you seeing an error? Please paste the stack trace, or add a screenshot for us to review:

This error might be due to missing dsym file path or newrelic is unable to upload dsym file for the first time.
Note - This error doesn’t stop application running into device or simulator.

How does that differ from what were you expecting to see?

  • In Xcode 9.0.1 we were not seeing this error but when we updated latest newRelic agent and run it into XcOde 10.1 we are seeing this error.

Kindly let us know the solution as soon as possible.

Regards,
Nishant Tyagi


#2

Hi @nishant.tyagi, are you seeing this error when build the app in simulator? The New Relic script ignores builds that target the simulator. That’s one reason you may see this error since the dsym doesn’t exist.

If this is not the case, is this app bit code enabled? With bit code enabled, the dsym has to be downloaded from iTunes and then uploaded to New Relic manually.

There’s a great post about dsyms that may be worth to check out: Relic Solution: iOS dSYM upload deep-dive

Hope this is helpful :slight_smile: