Your data. Anywhere you go.

New Relic for iOS or Android

Download on the App Store    Android App on Google play

New Relic Insights App for iOS

Download on the App Store

Learn more

Close icon

GitHub environment in new relic


Hi @RyanVeitch,

Thank you for sharing the information. I’m able to successfully deploy and see GitHub repo in browser entity. I have passed my token in the UI and then it gives blank screen. Can you help me out where I have went wrong ?


made this topic public #4


Hi @meghana.reddy - I’m not so sure on that - I’m going to loop in @jsius & @joelworrall - who may be able to help out.


@meghana.reddy what’s in your browser console output?



Thanks for that @meghana.reddy - That’s showing us how you have deployed the Nerdpack to your account.

Could you share the console output from your browser instead though?
See how to get to the console here: For Chrome, and here for Firefox.



@meghana.reddy, I need to verify two things:

  1. Did you set the GITHUB_URL in this file?
  2. Is the Browser application you’re trying access in the same account hierarchy as the account/APIkey under which the Nerdpack was deployed?


Also, it looks like the GITHUB_URL might have a space in it? That’s a potential bug that the code should account for… and I’m going to PR that project to that end.


@meghana.reddy, I believe I’ve fixed the issue. We have a PR we’re going to merge in the next day or so to address.


Thanks for sharing the information. After merging PR i will clone and run it locally and test it. Will let you know the updates.


Hi @joelworrall, when can I expect the PR merged code in GitHub?


The PR has been merged. Hope it helps.


@meghana.reddy have you tried to deploy using the latest version? I merged the PR a few weeks ago. I believe that version 0.3.0 will address your issue.


@meghana.reddy, I believe that if you use version 0.3.0 and set the GITHUB_URL to, you’ll be able to proceed.


I’m using my enterprise GitHub URL. So, I will have to change [] to my enterprise gihub url right? I have tried with latest version and still facing the same issue.


The console output that you posted earlier indicated an enterprise org on public github vs. an installed, private enterprise instance of GitHub. If it’s the former, is the correct URL.


Now I tried with the above url and I recieve the below error on the screen and also this ( x Error: Asset not found: /favicon.ico) in command prompt


Two things:

  1. Your service doesn’t have a name, does it? That’s a bug that the Nerdpack needs to account for.
  2. Let me look into providing another fix. I think we’re close to getting this resolved.


@meghana.reddy, I just published 0.3.1 tonight. Can you leverage that version, pointing at and let me know if that solves the problem? I believe it will.