HAProxy Integration Fails to Display Data

I am attempting to set up an HAProxy integration and am not seeing any data on the New Relic dashboard.

The guided install eventually stalls out during the HAProxy Integration Verification step. The only indication of something amiss in the logs is this: “Nov 23 16:54:27 AppGatV01 newrelic-infra-service[938407]: time=“2022-11-23T16:54:27-06:00” level=debug msg=“Failed to detect the cloud type, retrying in 60.000000 seconds””.

The logs from the host server are getting through to New Relic, so that seems to work. From there, I can even see HAProxy log out that it is getting successful stats requests. Nothing in the documentations seems to discuss what it means when the integration fails to determine the could type. Following the manual integration steps lead to the same place; no real errors besides the cloud type determination and no data visible to New Relic.

Currently running HAProxy EE 2.4 on an Ubuntu VM.

Hello @dmartin1 ,

Thank you for your query!

The error that is there is general error from the infra agent !

Can you search like nri-haproxy in the log file that would suggest something about the issue !

Also seems like the requirement here is not matched as we support 1.3- 2.2 version , that might be one if the reason . Please read this doc https://docs.newrelic.com/docs/infrastructure/host-integrations/host-integrations-list/haproxy-monitoring-integration/#comp-req

Best Regards,
Yasahswi verma

Attempting a fresh install, these are the only logs that indicate an error:

"Nov 28 11:22:32 AppGatV01 newrelic-infra-service[1704083]: time=\"2022-11-28T11:22:32-06:00\" level=warning msg=\"integration exited with error state\" component=integrations.runner.Runner error=\"context canceled\" integration_name=nri-haproxy runner_uid=9d3fa5d303 stderr=\"(no standard error output)\""
"Nov 28 11:22:32 AppGatV01 newrelic-infra-service[1704083]: time=\"2022-11-28T11:22:32-06:00\" level=warning msg=\"integration exited with error state\" component=integrations.runner.Runner error=\"exec: not started\" integration_name=nri-haproxy runner_uid=9d3fa5d303 stderr=\"(no standard error output)\""
time="2022-11-28T11:22:32-06:00" level=warning msg="integration exited with error state" component=integrations.runner.Runner error="signal: terminated" integration_name=nri-haproxy runner_uid=9d3fa5d303 stderr="[WARN] Using the deprecated config ClusterName instead of HAProxyClusterName"

Changing the integration YML file config key from CLUSTER_NAME to HA_PROXY_CLUSTER_NAME only removes the error about the deprecated config.