How to alter the depth of the transaction log

This is a brand new install on a LAMP server with PHP 7.

We have several files called /DefaultController/index - we need to be able to monitor some of them as key transactions, but New relic treats them all the same.

How do we alter the depth that New Relic labels the transactions to, so we get e.g.

/home/DefaultController/index
/backend/DefaultController/index
/catalogue/DefaultController/index

Thanks

Hi @developers3

If you’re using a Framework New Relic supports, generally New Relic follows a Controller/Action type naming convention.

There is no naming depth configuration, the general options are

  1. Take the given naming
  2. Manually name the transactions by passing newrelic_name_transaction() at the point of knowing that your route is
    /home/DefaultController/index
    /backend/DefaultController/index
    /catalogue/DefaultController/index

What framework are you currently using?

Thanks @acuffe (on behalf of the OP - my colleague).

For anyone who finds this - that’s the conclusion the OP came to. Support directed us to the php api docs, and from there we found a plugin for our framework, which we’ve just installed, and seems to have adjusted the naming conventions nicely.

For reference, the framework is Yii 1. New Relic automatically picked up the controllers and actions, but not the modules that our application is split into which meant we were getting many separate results rolled into one transaction.

Adjusting the transaction name at the routing stage was exactly what we needed - and is done out of the box by: https://github.com/gtcode/yii-newrelic

1 Like

@jevans

Magic, great that somebody has pieced together the modification in a github repo. Helps expidate the renaming.

Currently all our agents name to a specific convention, but i’ll file a feature request to suggest a depth of naming option in the agent. It’s not a guarantee the feature would be added but ensures the product managers involved in the agent will discuss it when planning are roadmap.