How to decrease cpu and memory metrics?

How can I increase the sample rate for cpu and memory metrics?
I increased to these values, but the amount of “goldenmetrics” collected is the same
metrics_network_sample_rate: 50
metrics_system_sample_rate: 30
metrics_process_sample_rate: 40

Thanks

Hi @vozpopuli, thanks for your question!

These are the correct settings to change to network, system and process sample rate in New Relic.

To adjust any of these you can add the setting in your newrelic-infra.yml file, for example:

metrics_system_sample_rate: 15

To enable these changes, you will need to restart the agent after changing the config file.

Please note that decreasing the pooling frequency can cause spikes in charts if you are seeing a very small timeframe, 5 minutes or less, as we won’t have many data points to draw the chart. Also, we don’t advise using sampling values above 60 seconds as it may impact your alerts, since our alert evaluation mechanism won’t have minute data to correctly evaluate the conditions.


Reference to the documentation for each of these settings:

1 Like