Infra and APM install failed

Hello,

I am trying to set up new relic APM on my website hosted on AWS server. I have tried this with two different ways.

1. newrelic.config file in .ebextensions folder with following code but it did not worked for

packages:
msi:
infrastructure: https://download.newrelic.com/infrastructure_agent/windows/newrelic-infra.msi
files:
“C:\Program Files\New Relic\newrelic-infra\newrelic-infra.yml”:
content: |
license_key: MY_LICENSE_KEY
commands:
01_stop-newrelic-infra:
command: net stop newrelic-infra
ignoreErrors: true
02_start-newrelic-infra:
command: net start newrelic-infra
ignoreErrors: true

2. Install new get package with command Install-Package NewRelic.Agent and then updated the License key in newrelic.config file

<?xml version=“1.0”?>
<!-- Copyright © 2008-2019 New Relic, Inc. All rights reserved. -->
<!-- For more information see: https://newrelic.com/docs/dotnet/dotnet-agent-configuration -->
<configuration xmlns=“urn:newrelic-config” agentEnabled=“true”>

<service licenseKey=“REPLACE_WITH_LICENSE_KEY” />

<application>

<name>Live</name>

</application>

<log level=“info” />
<transactionTracer enabled=“true” transactionThreshold=“apdex_f” stackTraceThreshold=“500” recordSql=“obfuscated” explainEnabled=“false” explainThreshold=“500” />
<crossApplicationTracer enabled=“true” />
<errorCollector enabled=“true”>
<ignoreErrors>
<exception>System.IO.FileNotFoundException</exception>
<exception>System.Threading.ThreadAbortException</exception>
</ignoreErrors>
<ignoreStatusCodes>
<code>401</code>
<code>404</code>
</ignoreStatusCodes>
</errorCollector>
<browserMonitoring autoInstrument=“true” />
<threadProfiling>
<ignoreMethod>System.Threading.WaitHandle:InternalWaitOne</ignoreMethod>
<ignoreMethod>System.Threading.WaitHandle:WaitAny</ignoreMethod>
</threadProfiling>
</configuration>

Can you please help me out of this where I am doing mistake here?

Hi @tiana.musisca - If you could specify which version of Windows the server is running and also whether you are installing the .Net Framework or the .Net Core agent, this would help us assist you.

One thing I would try is to attempt a re-install as an administrator level user and start the agents without moving any config files around. If that is not working then try the Troubleshooting sections for the respective agent

Hi @tiana.musisca,

Just reiterating here what Stefan said. This doc may help with regards to the Infra agent:

https://docs.newrelic.com/docs/infrastructure/new-relic-infrastructure/installation/install-infrastructure-agent-aws-elastic-beanstalk

1 Like

Hi Stefan,
I have following configurations

Windows Server 2016 Datacenter
.net framework 4.5.2

Thanks

Hi Tiana,

This Level Up post may help diagnose why the .Net agent isn’t reporting:

The infra agent will log data in the following locations:

The Default log locations are:

  • Amazon Linux, CentOS, RHEL: /var/log/messages
  • Debian, Ubuntu: /var/log/syslog
  • Windows Server: C:\Program Files\New Relic\ newrelic-infra\ newrelic-infra.log or C:\Windows\system32\config\systemprofile\AppData\Roaming\New Relic\newrelic-infra or C:\ProgramData\New Relic\newrelic-infra\
1 Like

Hello,

I have checked after install the newrelic .net agent on the server and it is logging data in new relic successfully but when I try to do the same with the publishing newrelic.config file in .ebextensions folder of my project. Then it is not working for me.

I took newrelic.config file from below link https://docs.newrelic.com/docs/infrastructure/new-relic-infrastructure/installation/install-infrastructure-agent-aws-elastic-beanstalk

it is working but installing newrelic-infra on the server. I need to install the new relic agent as well. Can you o please help me in this.

Thanks

Hi, @tiana.musisca: I wonder if this post will help:

https://notebookheavy.com/2017/05/01/auto-install-newrelic-agent-elastic-beanstalk/