Infrastructure Hosts Graph Time Picker Broken


The time picker in the Infrastructure hosts graph screen is broken. If you try to set or modify time ranges the picker sets a different time and/or date to what was selected.
Example I followed a link from the Incident page and it gave the below URL (removed account and server name):{"and"%3A[{"is"%3A{"entityName"%3A"SERVERNAMEXXXX"}}]}

This loads correctly, however, when i click on the time picker and change the end time to be 11:00pm from 10:00pm and click apply. It either ignores my request and shows the old data and time range or it changes the date and/or time to a different one than I selected. The effect seems to vary between time range I start on.

This has been happening for the last 2 weeks. I am using the latest version of Google Chrome.

I just took a look on mine and didn’t see this, but if the time range was long, like over days, then the times shown said things like midnight even though the data was going until 5am when I hovered over it. I tried zooming and then customizing and changing via picker, and then customizing. (Looked at the CPU chart times)

Did I miss a step or misunderstand somewhere?


I can’t seem to reproduce this behavior. Do you have a permalink to the account or a screenshot?

I can’t create a permalink to show the issue as when I try to apply the time range it shows me a different time range & the permalink is for the wrong time range.

To reproduce manually:{“and”%3A[{“is”%3A{“ec2InstanceId”%3A"i-01af813104661a828"}}]}&timeEnd=1595773800000&timeStart=1595770200000
Set the custom date range to: image
Click Apply and the date range shown isn’t the one selected. In this case its a day off.

However I do also see oddness in trying to highlight an area of the graph and it showing me a different zoom in timed. But I can’t show this outside of a screenshare and you don’t seem to offer that type of support?

Hi @helpdesk12

Thanks for those reproduction steps! I tried walking through them, but wasn’t able to recreate the issue:

One question I had, was your New Relic account provisioned via SSO from your company? Depending on how it’s setup, your account’s timezone information may be inherited from your identity provider.

The account is not on SSO, but standalone New Relic login credentials. Its a very old account migrated from AWS Servers (pre Infrastructure product). The account timezone is set to UTC, with this server being in UK time with summer time enabled (BST).

Hi @helpdesk12

Can you try creating a new user to see whether or not the issue persists across accounts?

I’m struggling to reproduce the issue on either the original account or a new user. I did come across something new though.

  1. Set a time range from August 5th 10pm to August 5th 11pm.
  2. Click in the “time to” box, currently 11pm.
  3. Under the “Jump To” select 6 hours (4am).
  4. The time has moved forwards, but the date hasn’t changed, so its looped hours on the same day.

I’m afraid this is similar to the last, in that we haven’t been able to replicate that.

Could you let us know if you have any browser plugins enabled that could be interfering with the timepicker?

If not, could you possibly take a screen recording and send it over? (You can dm it to me, rather than showing your data publicly)