Installing New Relic Infrastructure agent on Ubuntu 21.04 Hirsute

Hello,

Any workaround to install new relic infra agent on ubuntu 21.04? I am intending to use log ingestion however it fails to install.

    /usr/local/bin/newrelic install
[sudo] password for rafael: 

   _   _                 ____      _ _
  | \ | | _____      __ |  _ \ ___| (_) ___
  |  \| |/ _ \ \ /\ / / | |_) / _ | | |/ __|
  | |\  |  __/\ V  V /  |  _ |  __| | | (__
  |_| \_|\___| \_/\_/   |_| \_\___|_|_|\___|

  Welcome to New Relic. Let's install some instrumentation.

  Questions? Read more about our installation process at
  https://docs.newrelic.com/

	
INFO Validating connectivity to the New Relic platform... 
    ✅ Checking for data in New Relic (this may take a few minutes)...success.
The guided installation will begin by installing the latest version of the New Relic Infrastructure agent, which is required for additional instrumentation.

? Please choose from the following instrumentation to be installed: Logs integration, Golden Signal Alerts, Docker Logs integration, PHP Agent Installer

The following will be installed:
  Infrastructure Agent
  Logs integration
  Golden Signal Alerts
  Docker Logs integration
  PHP Agent Installer

==> Installing infrastructure-agent-installer...
there is no newrelic infrastructure agent available for the distribution 'hirsute'.
==> Installing infrastructure-agent-installer...failed.

From this page: Install the infrastructure monitoring agent for Linux | New Relic Documentation

printf "deb https://download.newrelic.com/infrastructure_agent/linux/apt focal main" | sudo tee -a /etc/apt/sources.list.d/newrelic-infra.list

…will yield the following error:

The repository ‘https://download.newrelic.com/infrastructure_agent/linux/apt hirsute Release’ does not have a Release file.

Hi, @preston.lee: Your deb command says focal, not hirsute. Is that a typo?

I’m running into the same issue except I’m using 20.10, groovy. Is there a way to install the newrelic tool even if there’s not an officially supported version?

When is support for 21.04 expected, or is stable unsupported, and we have to wait for the next LTS in 2022?

I’m experiencing the same issues above, the auto-installer fails, force downloading focal doesn’t accept the Release file, and modifying the commands to use hirsuite doesn’t work as the referenced URL https://download.newrelic.com/infrastructure_agent/linux/apt/dists/ does not list hirsuite or impish

Is there any feature request pages ? I’m looking forward to the support on 21.04 also.
I wonder if there are any workarounds for the moment ? I wonder if there are any workarounds to like installing the logger on some unfamous distros, for example.

HI @michael.lee1,

Thank you for reaching out to the Community! At this time I do not have an ETA that I can provide. But I would suggest that you monitor the New Relic forum, as this should be posted there when released.
What’s new in New Relic 1
New relic Release notes