JS Errors are missing stack traces for React SPA

I have been trying to test new relic integration on my React SPA. I am particularly interested in being able to monitor JS errors. I have tried to throw custom errors from my application and I am able to see the error names in the UI, however their stack traces are missing and I get the following message:

No stack trace available

We were unable to load a stack trace for the error you requested.

I have already scanned through all of the troubleshooting tips mentioned in https://docs.newrelic.com/docs/browser/new-relic-browser/browser-pro-features/javascript-errors-page-detect-analyze-errors
and tried all of possible workarounds with no success. Particularly I ensured that any error boundaries were removed, Also tried the noticeError API as well as the its try-catch version.

I’ve also looked at similar existing questions, but did not find a relevant answer:
https://discuss.newrelic.com/t/no-stack-traces-for-javascripterrors-unable-to-debug-js-error-or-where-it-comes-from/77090
https://discuss.newrelic.com/t/error-stack-trace-disappeared/110980

Permalink to new relic page: https://one.nr/0MRNOnlj

Method: copy/paste
Version: SPA

I’ve also verified that the same issue happens for both Chrome and Edge.

At this point, I have exhausted my options and looking for some help.

Thanks

1 Like

@kushagra.sharma I’m having the same issue. Following this thread

1 Like