Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

.NET Agent - no data - no agent logs


#1

Hello,

I’ve already installed and tested .NET Agent on my local computer and one of our environments with success (data shown in APM)

On next environment that we have, I’m completely lost. I did the same steps, used the same installers and no data is reported.

Based on different topics that I were able to find here, I’ve tried few things.

Here’s what we have and what I did:

  1. Windows Server 2012 R2 64-bit
  2. Web application run under IIS
  3. Installed .NET Framework 4.7.2
  4. Agent installer used: NewRelicDotNetAgent_x64.msi (downloaded on 25.07.2019)
  5. In newrelic.config, turned on log level to “debug”
  6. In folder C:\ProgramData\New Relic.NET Agent\Logs there are only NewRelic.Profiler.xxxx logs, no agent logs appeared
  7. I’ve added permissions (out of desperation, full control) to folder C:\ProgramData\New Relic for user, that is assigned in application pool for our application (in IIS)
    8). I’ve added read permission to registry (HKEY_LOCAL_MACHINE -> SOFTWARE -> New Relic -> .NET Agent) for user, that is assigned in application pool for our application (in IIS)
  8. There are no errors in NewRelic.Profiles.xxxx.log files, only Info and Debug
  9. Using process explorer, I can see that New Relic dlls are attached:

    11.Environment variables looks good:
    image
  10. After all I starde to edit newrelic.config by adding different attributes and fields that shouldn’t be needed (according to documentation):
  11. I’ve run diagnostic tool nrdiag_x64 and compared result with working environment. I don’t see any Error statuses here. Failuers are the same for both servers (the one New Relic is working and the one I have issue with), so I’m not suspecting it. Anyway here are those failures:

  12. Of course I’ve navigated our web app for few minutes.
  13. License key is the same as shown in account settings .

Any ideas for next steps?


#2

Based on your newrelic.config, I’m guessing you have either spelled the app pool name wrong (you have app pools disabled by default) or your app has AlwaysRunning enabled.

Either way, check the NewRelic.Profiler logs and you’ll likely see lines like “This process should not be instrumented, unloading profiler.”

There should be app pool names in parentheses in these logfiles populated by the APP_POOL_ID value that IIS sets when the app starts up. Make sure you have your app pool name in your newrelic.config matching what shows up in these logs.

“This process (someapppoolname) is not configured to be instrumented.”

However, if you are using AlwaysRunning then a race condition exists where the APP_POOL_ID value sometimes isn’t present when the app “warms up” so the profiler can’t enable the app pool based on the name. If this is the case you’ll see an empty parentheses like

“This process () is not configured to be instrumented.”


#3

Thank you very much for answer!

I’ve checked your ideas, but it didn’t helped me this time.

Today with fresh mind I looked again into newrelic.config file and I’ve figured out, that attribute autoStart=“true” is specified two times. After deleting second occurrence Agent started to work.

Anyway, I would call my issue solved now, but one thing is bugging me. As it might be connected with my solved issue, I’ll continue here.

In newly generated newrelic_agent_LM_W3SVC_2_ROOT.log file, I see some exceptions:

and

does it interfere with data that is visible APM?


#4

Hello @smalinowski

I am happy to hear you identified the issue and you were able to fix it too, great job.

Now, with the exceptions messages that you are seeing in the newrelic_agent_LM_W3SVC_2_ROOT.log
WARN.....GC Sample.
This will NOT interfere with data that is visible in APM.

However, if you don’t want to see those messages, you could disable this by adding disableSamplers=“true” in the Newrelic.config, please see example below.
`
<application disableSamplers=“true”>
<name>My App Name</name>
</application>

`

Perform IISRESET and do let us know if those exceptions messages stop recording.


#5

Hello,

Thanks, with disableSamplers=“true” there are no errors. Case solved.