Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

New NewRelic.AppName not updated in APM nor Browser


#1

I updated the value for the appSettings key for NewRelic.AppName in the web.config for my app. I did an IISRESET and browsed the site. It’s still showing the old name under APM > APPS and on BROWSER. How do I get it to show the new name?


#2

Hi @ets - Have you checked that the application has not been named in the newrelic.config for the agent?


#3

Have you checked out our documentation around naming applications

https://docs.newrelic.com/docs/agents/net-agent/configuration/name-your-net-application

The old name will show, up you should be able to change the Alias of the application. if you do this you will retain the existing gathered data.

If you have changed your name but its not showing, check all of the places listed in the doc above as it will show you there are about 5 different ways to do this.


#4

only place it’s named is in its web.config file. not in newrelic.config or anywhere else based on that document.


#5

one thing to note if you are simply changing the case of the name ie from APPNAME to AppName (or any variants), this will not change it will stay as APPNAME.


#6

good to know, but not the case.


#7

Silly question, everything compiled correctly and deployed successfully. Im right in saying this is in both APM and in Browser?

You could try to override everything by using the Environmental Variable method to deploy the name.

If you are using .NET agent version 6.17.387.0 or higher, you can use the environment variable NEW_RELIC_APP_NAME to set the application name. This name will take priority over an app’s local newrelic.config . However, this name will not take priority over the web.config (the app config file for web applications not on IIS) or the SetApplicationName API call.


#8

starting to wonder if the agent is even running… I just reinstalled latest version, had me restart IIS but not sure it’s even running. how can i tell? i tried net start newrelic-infra but it says service name is invalid


#9

yeah both APM and browser. now acting like not getting any traffic/data. I’m guessing renaming it affected that. but why is new name not showing up?


#10

I do have a “.” in the appname, that won’t cause issues, will it?


#11

No, a “.” in the application name will not cause issues.

You tried net start newrelic-infra which is the Infrastructure agent. This agent does not record APM and Browser data, it is the APM agent that provides this function. Have you installed the .Net Agent correctly?

You can check for APM agent errors on start up in the Windows event log to assist with troubleshooting.


#12

Hey @ets - were you able to restart the APM agent based on @stefan_garnham’s advice??

Let us know if you’re still having trouble.


#13

finally just resolved this. had nothing to do with anything already mentioned. We had disabled TLS 1.0 on our servers . After finding this post (TLS 1.2 Support in New Relic Server Agent), we followed the solution link suggestion to make sure strong cryptography (SchUseStrongCrypto) is enabled. ran the registration change and restarted the server. now all apps are reporting to newrelic. additionally seemed to resolve some of the Schannel TLS errors we were receiving