New Relic Account Maturity Nerdpack

The New Relic Account Maturity Nerdpack

We want to help our customers get more out of their accounts, and spot un-used features and functionalities to show how well they are maturing on using the New Relic Platform. There is a lot to New Relic and while our services are typically extremely easy to install, integrate and use, sometimes a setting or configuration or feature might be overlooked.

Enter the New Relic Account Maturity Nerdpack. It’s making use of the Nerdgraph API schema to ask a series of questions per product and produce some insight into whether you’re making use of your account and attempts to look across the account/sub-accounts upon which it was deployed, of course taking into account the permissions of the viewing user to find out where you could make potential improvements in usage or find gaps in your configurations.

As you can see it gives a scoring based on some weightings we believe are fair representation of really useful features in New Relic.

So from a high level you get a really good idea where there’s potentially additional value you can be getting out of your account. Lets go look at APM

Great so APM looks like we’re doing really well. In most cases we aren’t on the latest agent, OK, that’s good advice (not always actionable in every customers scenario but good to know). We also aren’t making use of Deployment Markers in the last few weeks. Something we could add in to get additional utility or maybe if we had previously integrated we now spot that it’s not working anymore. I also notice that Distributed Tracing isn’t possible on some of the agents I’m using AND that I don’t have Distributed Tracing enabled on all Applications. This could cause gaps.

Clicking on the scoring area of the account row will open a drilldown for that account in APM. This shows me which entities are degrading my score. Perhaps I have some inactive applications I can delete/remove to clean up my account, I can see which Entities have Distributed Tracing capable agents and if it’s enabled on that app with Span data reporting in.

Now you have actual actionable information to improve your usage of your New Relic account and ensure you have the power of Distributed Tracing, Deployment Markers, Latest agent features, using Labels and more.

For different New Relic products we will have different amounts of metrics, and as more API’s open in Nerdgraph we will add additional information to this Nerdpack.

Installation / Setup -

What steps are required to get up and running? Well actually it’s rather simple. Clone the repository to your local machine. Ensure you have Nerdpack Manager Role in your New Relic account. Generate a unique ID for your deployment and then install dependencies and either serve locally or publish and subscribe.

nr1 nerdpack:clone -r https://github.com/newrelic/nr1-account-maturity.git

cd nr1-account-maturity

nr1 nerdpack:uuid -gf

npm install

nr1 nerdpack:serve

Visit https://one.newrelic.com/?nerdpacks=local, navigate to the Maturity Nerdpack, and :sparkles:

To deploy to your account for everyone’s enjoyment. Instead of nr1 nerdpack:serve you can run the following 3 commands assuming your default profile for your New Relic CLI is the account you want. If not you can use the --profile=xxxx flag to specify. See developer.newrelic.com for more

    nr1 nerdpack:publish [--profile=your_profile_name]
    nr1 nerdpack:deploy [-c [DEV|BETA|STABLE]] [--profile=your_profile_name]
    nr1 nerdpack:subscribe [-c [DEV|BETA|STABLE]] [--profile=your_profile_name]

Support -

This Nerdpack is supported by the developers here in this community thread, or alternatively you can ask questions and in the Github Issues page. If you can fix the issue yourself, please do submit a pull request.

The full ‘Account Maturity’ Readme and Repo can be found here

8 Likes

I’m trying to clone this nerdpack, but am getting an error. I thought it may have been related to my work computer, but I tried on my home machine and received the same error. Any ideas?

Thanks!

Chris

Error from console:

npm ERR! prepareGitDep > maturity-products@1.0.0 prepare C:\Users\cjmar\AppData\Roaming\npm-cache_cacache\tmp\git-clone-91d47862
npm ERR! prepareGitDep > npm run build
npm ERR! prepareGitDep
npm ERR! prepareGitDep
npm ERR! prepareGitDep > maturity-products@1.0.0 build C:\Users\cjmar\AppData\Roaming\npm-cache_cacache\tmp\git-clone-91d47862
npm ERR! prepareGitDep > rm -rf dist && babel -d dist src
npm ERR! prepareGitDep
npm ERR! prepareGitDep
npm ERR! prepareGitDep 2> npm WARN install Usage of the --dev option is deprecated. Use --only=dev instead.
npm ERR! prepareGitDep ‘rm’ is not recognized as an internal or external command,
npm ERR! prepareGitDep operable program or batch file.
npm ERR! prepareGitDep npm ERR! code ELIFECYCLE
npm ERR! prepareGitDep npm ERR! errno 1
npm ERR! prepareGitDep npm ERR! maturity-products@1.0.0 build: rm -rf dist && babel -d dist src
npm ERR! prepareGitDep npm ERR! Exit status 1
npm ERR! prepareGitDep npm ERR!
npm ERR! prepareGitDep npm ERR! Failed at the maturity-products@1.0.0 build script.
npm ERR! prepareGitDep npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

Hi @chris.marling

Can you share the exact steps you are taking in order to run the nerdpack, as well as info on your environment?

Information such as: OS, NPM Versions, NR1 CLI Version, etc…


For reference, I am on CLI version 1.22.2 (Check with nr1 --version), on MacOS 10.15.4, Catalina.

I cloned this nerdpack a moment ago & it runs just fine. The steps I took are:

nr1 nerdpack:clone -r https://github.com/newrelic/nr1-account-maturity.git
...

cd nr1-account-maturity
...

nr1 nerdpack:uuid -gf
...

npm install
...

nr1 nerdpack:serve
...

Are you doing this too or anything different?

@chris.marling my guess is you’re on windows.

The commands it’s failing on are basic linux commands for building. This is on our radar to try provide a build file option for windows that has the equivalent. Time just hasn’t been on my side recently.

Another user reported similar and you can subscribe here. I’m hoping to get time to try find a solution soon.

1 Like

@chris.marling

I have a temporary fix posted in the github link mentioned above

a PR is submitted for review at the moment which will solve it long term. Thanks for reporting!

Thanks so much for the quick responses! Yes I’m on windows. I totally understand time being short in supply.

I’ll give it another try.

No worries at all. Glad I could find some time to get a solution.

1 Like