Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

New Relic MySQL Plugin unable to obtain database connection due to timezone error

database
java
mysql
plugins

#1

Hi New Relic,

Please help i have a server that i’m trying to configure New Relic so i can monitor my MySQL database. Apparently, new relic mysql plugin cannot obtain database connection due to timezone error. Below is exact error

[2020-05-15 08:27:49,457] ERROR com.newrelic.plugins.mysql.MySQL - Unable to obtain a new database connection: jdbc:mysql://localhost/ svcnewrelic/PASSWORD_FILTERED, check your MySQL configuration settings. The server time zone value ‘EDT’ is unrecognized or represents more than one time zone. You must configure either the server or JDBC driver (via the serverTimezone configuration property) to use a more specifc time zone value if you want to utilize time zone support.

Below are components:

Java Version is 8
[root@~]# java -version
openjdk version “1.8.0_252”
OpenJDK Runtime Environment (build 1.8.0_252-b09)
OpenJDK 64-Bit Server VM (build 25.252-b09, mixed mode)
[root@ ~]#

[root@ ~]# mysql --version
mysql Ver 8.0.12 for Linux on x86_64 (MySQL Community Server - GPL)
MySQL follows system time.

I also have mysql java connector 8.0.18, i have tried also using 8.0.12 but no luck.

[root@ ~]# cat /etc/redhat-release
CentOS Linux release 7.7.1908 (Core)
Server Time is EDT.

Your help is highly appreciated.


#2

Hi,

any help anyone? Will highly appreciate.

Thank you


#3

Hi @jdeluna

New Relic is moving away from the MySQL Plugin and towards its replacement, the MySQL on-host integration. This will be the long-term solution for MySQL monitoring so I recommend becoming acquainted with it. Here is the documentation on this:

You can get started with it here:

This requires an Infrastructure Pro subscription. The MySQL integration is more robust and has better support than Plugins. This means that using it should resolve your current issue. Here is more information: