Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

New Relic One terms and conditions


#21

You can ignore those warnings, you should still be ok!

The issue is that the Top Nerdpack doesn’t show up as a launcher on the NR One homepage. Instead you need to access it from it a host entity.

From https://one.eu.newrelic.com/?nerdpacks=local > Click into Entity Explorer > Filter to Hosts (on the left side bar) > Select a host > From the left sidebar see the Top Nerdpack.


#22

Thank you, @RyanVeitch, but I do not see it.
About the configuration running:

  1. Have 2 virtualbox VMs with Ubuntu 18.04 each
  2. Each VM has
  • Infrastructure agent, log gathering is enabled
  • Kubernetes agent (minikube is running)
  • Java agent installed in container together with Java application server (Shopizer)

Currently the nr1-top is running on NewRelic-Lab02

  • I do not see the application top in the entity explorer
  • I see each host twice one time as NewRelic-Lab0x and once as newrelic-lab0x (I installed everything on empty VMs cloned from the “gold image”). When I stop newrelic-infra both hosts disappear. When I start the agent both hosts come back
  • Interesting that the entity explore sees two newrelic-lab01, when the “old” interface sees newrelic-lab01 and NewRelic-Lab01
  • Log integration is detected by the old interface only (link “See Logs”) but noit by the entity browser

Screenshots
cannot see the “Top” entry in the “TROUBLESHOOT” section

Two agents in the “old” GUI

Infrastructure agent installation script:

Should I move it in another topic?


#23

Hmm, can you double/triple check that you are looking with /?nerdpacks=local on the URL?

If so, do you see any errors in the Browser console? Or, in your terminal window?


#24

Hi, @RyanVeitch
URL
https://one.eu.newrelic.com/launcher/nr1-core.explorer?nerdpacks=local&launcher=eyJ0aW1lUmFuZ2UiOnsiYmVnaW5fdGltZSI6bnVsbCwiZW5kX3RpbWUiOm51bGwsImR1cmF0aW9uIjoxODAwMDAwfSwiJGlzRmFsbGJhY2tUaW1lUmFuZ2UiOnRydWV9&pane=eyJuZXJkbGV0SWQiOiJpbmZyYS1uZXJkbGV0cy5ob3N0IiwiaXNPdmVydmlldyI6dHJ1ZSwiZW50aXR5SWQiOiJNamN4T1RBNU1ueEpUa1pTUVh4T1FYd3hOek14TVRjeE5URTNPVE16T0RjNE16VXoifQ==&sidebars[0]=eyJuZXJkbGV0SWQiOiJucjEtY29yZS5hY3Rpb25zIiwiZW50aXR5SWQiOiJNamN4T1RBNU1ueEpUa1pTUVh4T1FYd3hOek14TVRjeE5URTNPVE16T0RjNE16VXoiLCJzZWxlY3RlZE5lcmRsZXQiOnsibmVyZGxldElkIjoiaW5mcmEtbmVyZGxldHMuaG9zdCIsImlzT3ZlcnZpZXciOnRydWV9fQ==

Checked with safari, firefox and chrome - the same result. No errors

Safari

Chrome

Firefox


#25

This is weird! It seems you have done everything correct, so it should absolutely be showing up for you.

There is probably something really simple getting in the way here, so I’d like to take a step back, and start over. Could you walk through the below list, and see if it still doesn’t work?

Start this list while you are not locally serving the nerdpack! Log out of your New Relic account in your browser and delete NR cookies


  1. cd nr1-top
  2. nr1 profiles:default (Make sure you are selecting the profile you will log in to the account with.)
  3. nr1 nerdpack:uuid -gf (regenerating the UUID as a ‘just in case’ as that ~could be the issue.)
  4. nr1 nerdpack:clean
  5. nr1 nerdpack:serve
  6. Navigate to https://one.eu.newrelic.com/?nerdpacks=local (Make sure you are on the same machine that you are serving from)
  7. Login with the credentials of the user who owns the API key / Profile you selected in step 2.
  8. Click through to a host entity.
  9. Look for the top nerdpack.

Hopefully starting from scratch will get that nerdpack to show up for you. Sorry it seems that your first experience with nerdpacks hasn’t been a smooth one. Let’s see if we can wrap this up from here :smiley:


#26

Hi, @RyanVeitch,
sorry, mea culpa, I believe I understand, why I’m wrong - I had to start the browser on the same VM, where I deployed the nerd pack.
To start it remotely I had to publish it first.
Is that correct?
And just another question. The I start the nerd pack with nr1 nerdpack:serve - how can I stop it running - ctrl/c, then ps -ef | grep nr1 and then kill? Is there a more elegant way to do that?


#27

That’s correct, to see it on other machines it first needs to be published to the account, rather than locally served.

You do that by sequencing the following commands:

nr1 nerdpack:publish

nr1 nerdpack:deploy -c DEV|BETA|STABLE // (pick one of these 3 channels that works for you)

nr1 nerdpack:subscribe -c DEV|BETA|STABLE // (this should be the same channel you deployed to)

As for killing the locally served version, you’re right with CTRL+C

You don’t need to kill the NR1 Process with ps -ef | grep nr1, but if you would like to do that you can.


#28

Yes, thank you @RyanVeitch I got it running locally
Will publish now.
The issue is, that after I break the execution of nr1 nerdpack:serve with ctrl/c the process continues to stay in background


#29

Indeed, that isn’t running anything locally though, it is waiting to listen to the nr1 terminal commands.

It should have no impact by just running as a process in the background :slight_smile:


New Relic One Top Nerdpack