New Relic Platform Installer for Redis

Hi there,

we have read and understood this:

However, on a particular legacy host, we need to install the redis integration using NPI.
Could you point us to the right command? npi install redis doesn’t work.

We will obviously upgrade to the new flow, but we need this working first.
We appreciate all the help.

Thanks,

This support forum seems working very well for paid customers, it has been a week?
Meanwhile, the tags and categories have been modified 2-3 times but no answers…

Hi, @ops60: Please note this sentence in the post you referenced above:

If you’d like to continue to use plugins for your accounts, please contact your New Relic account team and we will work with you on a per-account situation.

Have you contacted your account team?

If I knew the relevant npi command I would tell you, but I don’t. You might try executing npi --help or npi install --help and see if they provide any useful information.

I tried, but I am unsure on how to reach them since I got this back:

Hi there,

We have not received your New Relic support request that was just submitted.
As of March 10, 2021, you are no longer able to create a New Relic support ticket by emailing support@newrelic.zendesk.com.

For customers with ticketed support as part of their subscription, please create a support ticket by clicking on this link(https://one.newrelic.com/redirect/support) and follow these steps when logged into your New Relic account:

  1. Click the ? icon in the upper right hand corner
  2. Click on “I need more help”
  3. Select “Create a Support Ticket”

Creating a support ticket directly within your account will expedite the process and improve our team’s ability to troubleshoot your issue more effectively.

If you have any additional questions, please reach out to your New Relic Account team

And yes, that means that I could not find the steps mentioned in the reply, so either it is hidden very well, or being a paying customer does not always entitle one to ticketed support?
I would very well like to be directed to our New Relic Account team so that I can get this expedited.
But at this point, I am beyond lost and could only find a link that pointed me to this support forum.

Thank you for elaborating Phil! It is appreciated. I have tried both commands but unfortunately that did not get us any further yet, I will paste the output below in case it might help though:

$ npi --help
New Relic Platform Installer is a command line utility for easily downloading, configuring and running plugins.

Usage: 
  npi <command>

Most popular commands: 
  add-service     Set up a plugin to run in the background
  alias           Set up an alias for a plugin guid
  available       Displays a list of available plugins
  config          Configure the npi tool
  fetch           Download a plugin to the filesystem
  install         Interactive setup of a new plugin
  list            Display information about plugins on the filesystem
  prepare         Prepare a plugin to run by setting up its config files
  remove          Remove a plugin from the filesystem
  remove-service  Remove a plugin as a background process
  start           Start a plugin process (both foreground and background supported)
  stop            Stop a plugin's background process from running
  where           Displays the location of this plugin on the filesystem

Flags: 
  -h, --help     Print this help information
  -v, --version  Print the current npi tool's version

Example flows: 
  Interactive: 
    npi install <plugin>

  Manual: 
    npi config set license_key <YOUR_LICENSE_KEY>
    npi fetch <plugin>
    npi prepare <plugin>
    npi start <plugin> --foreground
    npi add-service <plugin> --start

Additional help: 
  npi <command> --help or -h

and

$ npi install --help
Walks you through the process of setting up a plugin for the first time

Usage: 
  npi install <plugin> <flags>

Flags: 
      --distro=<distro>    * Linux only * Set distribution family of your computer. [debian or redhat]
  -n, --noedit             Do not open 'plugin.json' in an editor
  -s, --start              Start the plugin service in the background after the operation is complete
  -q, --quiet              Limit console output
  -u, --untrusted          Allow use of local 'manifest.json' file
      --user=<user>        * Linux only * Required field to set the plugin service to run as this user
  -y, --yes                Auto-accept all prompts

@ops60 I have reached out to your account team to see if they have further insights.

From the message you included it looks like you were going through the support portal. So want to make sure that you are aware of this form that is available to connect you with accounts, billing, etc: Upgrade or manage your New Relic account

2 Likes

Thank you @JoiConverse – however, we are 2+ weeks further and nothing has changed for us.

We have also checked the form and reached out, yet nothing happened after that.

The only thing we got was another notification email “Important reminder: End-of-Life (EOL) notification for New Relic Plugins” without ability to reply in the mail today…

@ops60 Sorry for the wait and realize this experience has been frustrating. To further clarify, the NPI installation method is not tested or supported. I did however open a ticket for your request to make sure it is being routed to the account team. You should hear from them soon.

1 Like

@JoiConverse thank you, that’s greatly appreciated! Have a lovely day ahead :slight_smile:

@ops60 I have had more discussion about this with our team and it was determined that account teams are also not able to assist with the NPI installation. That is why there has not been a response on the ticket. Sorry if I steered you in the wrong direction.

If you have other support needs please let us know :slight_smile: