Your data. Anywhere you go.

New Relic for iOS or Android

Download on the App Store    Android App on Google play

New Relic Insights App for iOS

Download on the App Store

Learn more

Close icon

NewRelic daemon container resolves domain to



I’m trying to install PHP Agent and daemon in separate containers (the recommended way). I managed to get everything installed and all containers start correctly.

The PHP agent is installed from the tar.gz file ( version The daemon is started from docker newrelic/php-daemon:9.8.0 image.

From the agent side, everything works as expected, it can connect to the NewRelic daemon. The problem exists on the demon side.

When app is running I can see in the logs that PHP Agent connects to daemon and sends the request data, but later daemon fails with:

newrelic_1  | 2020/03/26 18:47:57.379611 (21) Warning: app 'MY_APP_NAME' connect attempt returned Post{LICENSE}&marshal_format=json&method=preconnect&protocol_version=16: dial tcp getsockopt: connection refused

It clearly cannot access the, somehow it resolves to I did bit more digging and:

# ping
PING ( 56 data bytes
64 bytes from seq=0 ttl=56 time=20.518 ms

# ping
PING ( 56 data bytes
64 bytes from seq=0 ttl=64 time=0.086 ms

# ping
PING ( 56 data bytes
64 bytes from seq=0 ttl=64 time=0.090 ms

# ping
PING ( 56 data bytes
64 bytes from seq=0 ttl=237 time=201.090 ms
64 bytes from seq=1 ttl=237 time=150.759 ms

The newrelic daemon can resolve any address, but and is resolved to

I also tried to run dig and this is the result
# dig

; <<>> DiG 9.14.8 <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 62948
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 4096
;		IN	A


;; Query time: 3 msec
;; WHEN: Thu Mar 26 19:21:21 UTC 2020
;; MSG SIZE  rcvd: 67

This is the way how I start the daemon (by using docker-compose)

            image: newrelic/php-daemon:9.8.0
                - overlay
            command: /usr/bin/newrelic-daemon --address=newrelic:31339 --watchdog-foreground

This problem also existed on 9.7.0.


Ok, just found the issue. It’s the pihole instance in network that blocks access to


Thanks for sharing what the issue was. I’m going to mark it as solved and leave this topic open for other Explorers to view in case they have a similar issue.