No data coming through with NuGet installed agent

Version 8.22.181 deployed with NuGet
.NET Framework 4.6.1
Windows

I have just created my account for the first time. There is no sign of any data in my account.

My environment variables are set as follows (at the User level):
COR_ENABLE_PROFILING=1
COR_PROFILER=71DA0A04-7777-4EC6-9643-7D28B46A8A41
COR_PROFILER_PATH=D:\myapp\bin\newrelic\NewRelic.Profiler.dll
NEWRELIC_HOME=D:\myapp\bin\newrelic
NEW_RELIC_LICENSE_KEY=mylicensekey
NEW_RELIC_APP_NAME=My App Name

I tried running nrdiag and received the following output:

Check Results
-------------------------------------------------

Info                Base/Env/CollectEnvVars [Gathered Environment variables of current shell.]
Success             Base/Config/Collect
Success             Base/Config/Validate
Failure             Base/Log/Copy
Failure             DotNet/Agent/Installed
Info                Base/Env/HostInfo [DESKTOP-8OU9LLU]
Success             Base/Config/LicenseKey
Info                Base/Config/RegionDetect [1 unique New Relic region(s) detected from config.]
 ] o                Node/Env/Version [v9.7.1
Info                Node/Env/NpmVersion [5.6.0]
Success             Base/Env/CheckWindowsAdmin
Info                Base/Env/DotnetVersions [v2.0.50727, v3.0, v3.5, v4, v4.0, v4.7 or later]
Info                Base/Env/DotNetCoreVersions [2.1.100, 2.1.201, 2.1.202, 2.1.301, 2.1.4, 2.1.403...]
Info                Base/Containers/DetectDocker [Docker Daemon is Running]
Success             Base/Collector/ConnectUS
Success             Node/Env/VersionCompatibility
Warning             Base/Config/AppName
Info                Base/Env/IisCheck [Version 10.0]
80 results not shown: 80 None
See nrdiag-output.json for full results.

Issues Found
-------------------------------------------------
Failure - Base/Log/Copy
Log File not found, please check working directory
See https://docs.newrelic.com/docs/new-relic-diagnostics#run-diagnostics for more information.


Failure - DotNet/Agent/Installed
Could NOT find one or more dlls required by the .Net Agent. Either the .NET Agent is not installed or missing essential dlls. Try running the installer to resolve the issue.


Warning - Base/Config/AppName
No New Relic app names were found. Please ensure an app name is set in your New Relic agent configuration.
See https://docs.newrelic.com/docs/agents/manage-apm-agents/app-naming/name-your-application for more information.

The .NET Agent should be installed - I can see its DLLs sitting in the /bin/newrelic/ folder.

Hello,

Are any log files being created in D:\myapp\bin\newrelic\logs? If so, are there any logs for your application?

Thanks,

Don

Hi, thanks, I managed to get it working after reinstalling the agent. Not sure what was wrong.

1 Like

Thanks for confirming that fixed it for you :smiley: