[Node] Data not loading for NodeJs application

Hello,
I have follow the steps as provided for Node Js installation. but still I am not able to see my data.

  1. Use the command npm install newrelic --save for each application you want to monitor.
  2. From node_modules/newrelic, copy newrelic.js into the root directory of your app.
    3 Configure agent via the newrelic.js file or via environment variable:
    -Customize the license_key setting with your license key.
    -Customize the app_name setting with one or more meaningful app names.
  3. Add required (‘newrelic’); as the line of your app’s main module.

Hi, @sandeep.s: You may find this document helpful:

https://docs.newrelic.com/docs/apm/agents/nodejs-agent/troubleshooting/troubleshoot-your-nodejs-installation/

Point No.6: Check for data

Continue running after that showing retry.
getting this message :This is taking longer than it normally does. Would you like to retry?

Hello,
Are you able to provide the proper solution.

Hi @sandeep.s - I just took a look in your account and see data reporting for the application names RMS STG NR on account 3306176. Are you also seeing data reporting now? Or is there another account/application we should be looking at?

this is RMS STG NR fine working as expected.
trying to add for Node Js. which are not picking the data, even I have perfomed steps as suggested by your support team…
in same account 3306176.

Have you tried the other troubleshooting steps, such as checking the agent log file?

I cannot suggest anything more than what is listed in that document (to be clear, I am a trainer, not a support engineer).

1 Like

Yes Sir, i tried but not able to resolve it my shelf that’s why looking help.

Thanks @sandeep.s - the last troubleshooting step I can recommend is to run the New Relic Diagnostic CLI. This will check for a number of issues that prevent a successful agent installation.

If running the Diagnostic CLI does not make the problem clear, let me know and we will get you connected with a Node specialist.

Sir, CLI command ./nrdiag_x64 , but it is not running in my terminal, using 3.10.0-862.11.6.el7.x86_64 Ubuntu Linux EC2.

OK @sandeep.s - thanks for trying. Please hold tight while I get someone with a specialty in the Node agent who can help you.

Hello Hross,
Happy new year in advance!
Could you please help us to provide update on this issue ?

I am looking your kind support to resolve the issue.

Hi @sandeep.s - I have escalated this to the team that can take a deeper dive with you. They will connect as soon as they are able. Happy new year to you as well!

1 Like

Hi @sandeep.s -

First, let’s go through a few common causes for the Node agent to fail to connect to the collector that we should rule out:

  • Incorrect License Key: Confirm the License Key in your configuration or environmental variables matches your account License Key. You can find this key by clicking on your user in the top right corner of the UI, and select Account settings. The license key is on the right side of that page.

  • Firewall Restrictions: Ensure that you allow traffic to the IPs used by New Relic verify that the proper user permissions are in place, no firewall rules are in place on the host itself, and security policies like SELinux are permitting New Relic or third party tools like AppArmor or GRSecurity are not interfering.

  • High Security Mode: You application’s High Security Mode configuration must match that of your account, either false or true for both your application and account

  • If using a Proxy: Verify New Relic is correctly set to use your proxy in the agent configuration. If your proxy is configured to accept connections over http, try setting ‘proxy’ to a fully qualified URL(e.g http://proxy-host:8080). When setting proxy_host and proxy_port New Relic attempts to connect over TLS(https).

Moreover, could you share a link to your application in New Relic One? Only those on your account and New Relic Admins will be able to view your application. To create a permalink within the New Relic, you can use the ‘Share’ button in the top right corner under your user profile or share the full URL from any page.

1 Like

Thanks for Looking this issue. The 4 points are okay which are gave.

Please find the permalink:
https://onenr.io/0Lkjn9qE9Ro

Let us know if any details are required, looking help on priority.
attaching here completed steps which has followed.
new-relic-install-nodeJs.pdf (657.1 KB)
URL: https://one.newrelic.com/launcher/nr1-core.explorer?platform[filters]=Iihkb21haW4gPSAnQVBNJyBBTkQgdHlwZSA9ICdBUFBMSUNBVElPTicpIg==&platform[accountId]=3306176&platform[timeRange][duration]=1800000&platform[$isFallbackTimeRange]=true&pane=eyJuZXJkbGV0SWQiOiJucjEtY29yZS5saXN0aW5nIiwiZmF2b3JpdGVzIjp7InNlbGVjdGVkIjp0cnVlLCJ2aXNpYmxlIjp0cnVlfSwibGFzdFZpZXdlZCI6eyJzZWxlY3RlZCI6ZmFsc2UsInZpc2libGUiOnRydWV9fQ==&sidebars[0]=eyJuZXJkbGV0SWQiOiJucjEtY29yZS5jYXRlZ29yaWVzIiwicm9vdE5lcmRsZXRJZCI6Im5yMS1jb3JlLmxpc3RpbmciLCJmYXZvcml0ZXMiOnsic2VsZWN0ZWQiOnRydWUsInZpc2libGUiOnRydWV9LCJsYXN0Vmlld2VkIjp7InNlbGVjdGVkIjpmYWxzZSwidmlzaWJsZSI6dHJ1ZX19&state=5ca7b2f2-d93d-5684-6893-328d138106b1

@sbedi, Could you please provide an update on this ?
I really appreciate your quick solution.

@sbedi I am still waiting for your assistance to resolved the issue.

Hi @sandeep.s -
It looks like we’re going to need to dig into some log files and collect some other private information. We are working on getting a case created for you - please check your inbox! If you do not receive an email with the case information in the next few days please reply here and let me know.

@sbedi Do we have any progress on this, I am still waiting your support to resolve it.

@sbedi, Could you please help us to provide an update.