Your data. Anywhere you go.

New Relic for iOS or Android

Download on the App Store    Android App on Google play

New Relic Insights App for iOS

Download on the App Store

Learn more

Close icon

Node v11 support


Latest node-newrelic 4.12.0 is currently restricted to v10 Node versions maximum through engines field in package.json, causing installation compatibility issues like:

error newrelic@4.12.0: The engine “node” is incompatible with this module. Expected version “>=4.0.0 <11.0.0”. Got “11.3.0”
error Found incompatible module

I’m using the latest Node in development machine and so far the agent is working fine.
Any plans to bump the engine version?


Hi @mihkelsokk, our agent generally works and coincides with the latest LTS version of Node, so this is the rate at which it will update, all depending on the Node LTS version.

You could try adding --ignore-engine after yarn install command, though keep in mind this is not officially supported by New Relic so you will be limited to Community help if you run into any errors.

Hope this helps :slight_smile: