NRI-KAFKA integration

We have problems to configure SASL_SSL authentication on NRI-KAFKA integration version 2.12 After several hours of attemps we are obtaining always the same error

Failed to get list of brokers: failed to create boostrap broker: create SASL_SSL config: all sasl_gssapi_ arguments must be set for SASL_PLAINTEXT auth,*

trying do deep down with error

All sasl_gssapi_* cannot be filled because kerberos authentication is not used in this case

  • SaslGssapiRealm
  • SaslGssapiServiceName
  • SaslGssapiUsername
  • SaslGssapiKeyTabPath
  • SaslGssapiKerberosConfigPathtls_ca_file

Official documentation still not mentions SASL_SSL authentication scheme

https://docs.newrelic.com/docs/integrations/host-integrations/host-integrations-list/kafka-monitoring-integration#install

Do you have a sample of working configuration file?

Thank you in advance

Hi @monitoring21, the documentation states:

bootstrap_broker_kafka_protocol : the protocol to use to connect to the bootstrap broker. Supported values are PLAINTEXT , SASL_PLAINTEXT , SSL , and SASL_SSL . Note: The SASL_* protocols only support Kerberos (GSSAPI) authentication. Default: PLAINTEXT.

This means that you are only able to use SASL_* if Kerberos (GSSAPI) authentication is in use. However, you say that Kerberos is not in use. Perhaps this is the issue?

In regards to the example configuration file, 3 of them can be found here:

They do not work “out-of-the-box” because all configurations must be changed to match your environment.

Hey @monitoring21 - Was Gene’s message helpful for you? Let us know if you need anything more on this :smiley:

There is a Github issue raised here for support if you would like SASL_* to work with non-Kerberos environments (which is almost always the case with a lot of companies).

1 Like

Hi @Volkan.Poyraz,

Welcome to the Explorers Hub and thank you for providing that update. I am certain this will be helpful to other members in the community.

1 Like