Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

Rails App: Thread Profiler stuck and not starting

threadprofiler

#1

Hi,
Have started the thread profiler sometime ago, it still shows the same “Waiting for instance to start profiler…”. Any suggestions as to how to go about it.

Thanks


#2

Hey @devalerts - is this still happening for you? Let us know if you’re still having trouble with the thread profiler, and if you are, please send back a link to the application :smiley:


#3

Hi @RyanVeitch ,

It is still the same, have attached a screenshot,

I don’t see a permalink on the Thread Profiler Page.

Thanks :slight_smile:


#4

Hey @devalerts - I’m not most familiar with Thread Profiling, however I have spoken to some colleagues here in NR, who say that there can sometimes be issues with profiling long time periods. Could you try again, selecting the shortest possible time period? if this fails as well we’ll need to get agent logs.

Thanks in advance.


#5

Hi @RyanVeitch
Tried with 1minute which is the shortest possible duration. Still the same.
With regards to Agent Logs, There is a lot of dump in Log, could you please help with keywords to grep which might help us with solving the issue.


#6

@devalerts - I’m going to get a ticket opened up for you so that our Ruby experts can help you with the logs :smiley:


#7

Sure @RyanVeitch thanks :slight_smile:


#8

No worries @devalerts - and Happy New Year.

If you get a solution to this in your support ticket, please do post that back here in case others face the same issue :smiley:

Cheers
-Ryan


#9

Hi @RyanVeitch Thanks for helping out, all we had to do was update the newrelic_rpm gem and we were able to resolve the thread profiling issue.


#10

Awesome! Sounds like a simple enough fix, thanks for letting us know here. I’m glad you got it sorted out.