Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

Relic Solution: Using Synthetics to Monitor SSL Expiration

rfb

#41

@stefan_garnham Thanks for your help here, and for pinging me on this.

@yograj.patel -

The 403 Forbidden error is happening as we post the events to Insights. The Insights Insert API will return 403s when it cannot authenticate the API key, I replicated this by ensuring my account had no access to insights (Insights None subscription), I still used the correct API key & account ID…

When I enabled the appropriate subscription for my account the monitor ran fine…

In testing this, I also substituted a false API key, and got the same 403 error, fixing the API key fixed the error.

So this points to two possibilities;

  • Wrong API Key.
  • Most likely - I opened your account and I can’t see any insert API key listed in the SSL cert test script I can find. Could you PM me with the API key you are using and can I have your permission to test the script in your account myself?
  • Invalid subscription.
  • This makes a little less sense to me, I can see from your account that you have Insights Pro, additionally I asked our engineers to look at your account in the DB and we see the appropriate subscriptions there.

Like I mentioned, my thoughts currently are that this is an API key issue. If possible, please do PM me the API key (or link to it) so I can run a test here to validate the behaviour you are seeing.

If we can replicate this with that information we’ll get this escalated further for investigation.


#42

@RyanVeitch I have provided the api key details and the account ID info. Please verify and assist me.


#43

@yograj.patel - Thanks for sending that over. That looks like your Admin account API key.

For the Insights Insert API you’ll need a different key.

There are 2 Insights specific API keys, 1 for inserting data and 1 for querying. In this case you’ll need an Insert key which you can find here: https://insights.newrelic.com/accounts/1175115/manage/api_keys

Let me know if updating that key helps :smiley:


#44

Thanks Ryan, it worked.


#45

Thanks! That worked. I’ve tweaked it a bit to generate different error messages but in a nutshell it works!