[Ruby] Custom Metric not showing up in newrelic

We are using Newrelic Ruby Agent for monitoring our Ruby on Rails Application in Newrelic.
In order to report Custom Metrics in New Relic, we are running a rake task being launched out of a CRON bash script. We have used https://docs.newrelic.com/docs/agents/ruby-agent/features/ruby-custom-metrics as our reference documentation for implementation.
The Newrelic call is as follows and does not give errors in the newrelic log.
::NewRelic::Agent.record_metric((‘Custom/Reports/memory_used’, percent)
However, we are not able to see the metric in Newrelic as mentioned in your docs at https://docs.newrelic.com/docs/insights/new-relic-insights/explore/metric-explorer-search-chart-metrics-sent-new-relic-agents.

Hello @relicusr,

Thank you for contacting us using our Forum! If you have followed the Metric Explorer documentation and are still unable to see these custom metrics report to APM, we will want to dive further into the Ruby agent to determine if we are able to accurately detect these metrics. I went ahead and opened a support ticket for you and will contact you shortly with the next steps to begin troubleshooting.

I can not find them either

Hi there- thanks for posting to the community!

To help dig into this issue, could you please follow up with a code snippet to exemplify how you are using the record_metric API?

Additionally, it would be helpful if you could send a link to the application you are referencing.

Cheers!

– Sara

I’m having this exact same issue as the first poster. @sschultz, are you able to look into it, or have any suggestions?

@eric50 Welcome to the community! :slight_smile: @sschultz is now working on another team at New Relic. Given the age of this request could you be more specific about what you are experiencing? I want to make sure to get the most appropriate support team notified to work with you. Thanks!