SystemSample hostname disappeared/delayed

Each day when I run the below New Relic Query:
SELECT uniques(hostname) FROM SystemSample WHERE hostname LIKE ‘ABC%’ SINCE 1 hour ago ==> Nothing is shown
SELECT uniques(hostname) FROM SystemSample WHERE hostname LIKE ‘ABC%’ SINCE 1 week ago ==> All ABC% hostnames were shown
It seems hostname was either disappeared or delay writing-to/captured-by SystemSample

Hey @Raymond_SK_Li, Could you send a link to this query in Insights (Only New Relic employees can access this link)

I “masked” the hostname
The following has no results returned
https://insights.newrelic.com/accounts/1737705/dashboards/1246911?query=SELECT%20uniques(hostname)%20FROM%20SystemSample%20WHERE%20hostname%20LIKE%20’ABC%’%20SINCE%201%20hour%20ago
The following has results returned
https://insights.newrelic.com/accounts/1737705/dashboards/1246911?query=SELECT%20uniques(hostname)%20FROM%20SystemSample%20WHERE%20hostname%20LIKE%20’ABC%’%20SINCE%202%20weeks%20ago

If the samples appear to be coming in significantly delayed, something to watch for is what the local time shows on your servers. The samples gathered by the Infra agent use the timestamp provided by your operating system and if there’s an offset, it can make them appear to be arriving late. A quick way to test is to compare the date on your host to the timestamp returned by our API’s web server:

$ date ; curl -sI https://infra-api.newrelic.com | grep ^Date:
Fri Jul 31 16:10:44 PDT 2020
Date: Fri, 31 Jul 2020 23:10:44 GMT