Terraform execution always fails with 403

I’ve been trying to create a dashboard in Terraform since last week.
But, “Terraform apply” fails with a 403 error.

I attach the terraform provider and the execution result.

provider "newrelic" {
  version = "~> 2.7.4"
  api_key = "NRAK-**********"
  admin_api_key = "NRRA-**********"
  account_id = "*******"
  region = "US"
}
[10:15:58][takumi-suzuki@PCD-074 dashboard]$ printenv |grep NEW_RELIC
[10:16:05][takumi-suzuki@PCD-074 dashboard]$ terraform apply

An execution plan has been generated and is shown below.
Resource actions are indicated with the following symbols:
  + create

Terraform will perform the following actions:

  # newrelic_dashboard.client-app will be created
  + resource "newrelic_dashboard" "client-app" {
      + dashboard_url     = (known after apply)
      + editable          = "editable_by_all"
      + grid_column_count = 3
      + icon              = "bar-chart"
      + id                = (known after apply)
      + title             = "client-app"
      + visibility        = "all"
    }

Plan: 1 to add, 0 to change, 0 to destroy.

Do you want to perform these actions?
  Terraform will perform the actions described above.
  Only 'yes' will be accepted to approve.

  Enter a value: yes

newrelic_dashboard.client-app: Creating...

Error: 403 response returned: You do not have privileges to perform this action.

  on main.tf line 9, in resource "newrelic_dashboard" "client-app":
   9: resource "newrelic_dashboard" "client-app" {


[10:16:11][takumi-suzuki@PCD-074 dashboard]$ 

It has been confirmed from the CLI that api_key can be used normally.
Also, the account permissions are Admin.

I just send you a dedicated support ticket for this issue. Could you check the ticket?

Hi Team,
We are also facing the same issues, where the plan and apply worked for the first time. But fails after it inconsistently. We have cross-checked with the permissions and roles for the respective API keys used.

Hi @Bikash.Singh Understand that your issue is similar to this one but there are differences between how support is handled based on region. I’m going to reach back out to our developer SMEs to make them aware of your followup questions in the other thread.

1 Like

@JoiConverse I have still not received any updates on the other thread, could you please provide any update on the same. Thanks.
@ttanaka Could you please confirm if you’ve any updates on your dedicated support ticket, if possible could you please share the thread for it.

Hi Team,
Is there any update on the above issue, it still seems to be an on-going issue.

@Bikash.Singh It looks like you have a response from @sblue on the other thread. :slight_smile:

1 Like