Unable to delete Synthetic monitor

I’ve been unable to delete a synthetic step monitor. I believe it’s in some sort of bad state, as I can’t load the monitor settings in the UI. I’ve also tried deleting using the NerdGraph API but I get this response:

{“data”:{“syntheticsDeleteMonitor”:null},“errors”:[{“extensions”:{“classification”:“DataFetchingException”,“errorClass”:“NOT_FOUND”},“locations”:[{“column”:9,“line”:3}],“message”:“Monitor does not exist or has already been deleted”,“path”:[“syntheticsDeleteMonitor”]}]}

Even though the monitor definitely exists.

Let me know if there’s any additional information needed. The situation sounds similar to https://discuss.newrelic.com/t/deleted-synthetics-monitor-still-exist-in-ui/112884.

Would appreciate any assistance with this, thanks!

Hi @Arao4

Thanks for reaching out, I hope you are well.

Also congrats on your first post in the Explores Hub.

Firstly ca you please provide a link to the synthetic monitor you are attempting to delete?

Additionally It may be that you have Synthetics Permissions enabled. This would mean you would have only have permission to view monitors. With the link ( requested above ) I should be able to confirm this.

Also it may be work ensuring you are following the correct process as shown in your Docs, including have the correct permissions.

Looking forward to hearing from you.

Hi @dcody

This is the monitor in question - https://one.newrelic.com/nr1-core/synthetics-nerdlets/monitor-overview/MzQ5NTY1NnxTWU5USHxNT05JVE9SfDQzNzZlNGJmLTc1N2QtNDYyNS1hNjQzLTg3NjdkMTEzZDhiNQ

I’ve been able to delete other monitors so I don’t think it’s a permissions issue. The Settings > General page is not loading on this particular monitor.

Thanks!

The monitor no longer exists, I’m not sure how it was cleaned up, but this is resolved now.