Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

Unable to start new relic ONE application


#1

Hi,
new to relic ONE.
Wanted to create new relic ONE application and for that aim I followed the steps at
https://one.newrelic.com/launcher/developer-center.launcher#pane=eyJuZXJkbGV0SWQiOiJkZXZlbG9wZXItY2VudGVyLmRldmVsb3Blci1jZW50ZXIifQ==

up to step 4 all worked well apparently. But when i wanted to perform step 5 to create sample code, I got (I am running that on linux):

nr1 create --type nerdpack --name my-awesome-nerdpack --verbose
init version: @oclif/command@1.5.19 argv: [ ‘–type’,
‘nerdpack’,
‘–name’,
‘my-awesome-nerdpack’,
‘–verbose’,
[length]: 5 ]
Using profile market-logic-software-ag_1
Copying files from /usr/lib/newrelic-cli/node_modules/@datanerd/3pp-cli-nerdpack-registry/templates/nerdpack to /home/beg/my-awesome-nerdpack
Request: POST https://artifact-registry.service.newrelic.com/graphql
Data: mutation {
generatePackageUuid
}
Headers: {
‘API-Key’: ‘NRAK-REDACTED_KEY’,
‘Content-Type’: ‘application/graphql’
}

:heavy_multiplication_x: Error: 403 - Forbidden. Your API key may be missing or be invalid

{ origin: ‘service-gateway’ }

I tried also to add the --api-key option but nope.

Any help is highly welcomed


#2

tried the same on Mac. Same problem


#3

Hey @beg1 - Can you share a screenshot of your terminal with the output of:

nr1 profiles:list

??


made this topic public #4

#5

Name Region API key


market-logic-software-ag_1 (default) us


#6

Hey @beg1 - You mentioned that you worked through this link:

https://one.newrelic.com/launcher/developer-center.launcher#pane=eyJuZXJkbGV0SWQiOiJkZXZlbG9wZXItY2VudGVyLmRldmVsb3Blci1jZW50ZXIifQ==

Which implies you created your api key and profile in the US region. (Your latest comment confirms that the profile is configured for the US region.)

I note that your account is in the EU datacenter though. So -

First, you should remove the bad profile with:

nr1 profiles:remove market-logic-software-ag_1

Then you’ll need to start again with https://one.eu.newrelic.com to create a new profile - just ensure your profile set up looks like:

nr1 profiles:add --name My_Account_Name --api-key NRAK-REDACTED_KEY --region eu

Would you be able to to try that and let me know how it goes?


#7

ok, thx, will try what you wrote…


#8

thanks man, that was the solution! Now I will start to develop our custom application


#9

Fantastic! Let us know what you come up with when it’s done :smiley:


#10

unfortunately another problem: I get the example project code rendered now (I call it mls-max-duration), but when I want to start (nr1 nerdpack:serve) I get

Nerdpack:

package.json:
:heavy_check_mark: name mls-max-duration
:heavy_check_mark: id 280329da-d4eb-44ca-abae-e81b724fc207

Found and loaded 2 artifacts on mls-max-duration (280329da-d4eb-44ca-abae-e81b724fc207) Nerdpack.
Artifacts:

Launchers:
:heavy_check_mark: mls-max-duration-launcher launchers/mls-max-duration-launcher/nr1.json

Nerdlets:
:heavy_check_mark: mls-max-duration-nerdlet nerdlets/mls-max-duration-nerdlet/nr1.json

:hammer_and_wrench: Built artifact files for:
⁎ 280329da-d4eb-44ca-abae-e81b724fc207–mls-max-duration-nerdlet built :heavy_check_mark:
⁎ 280329da-d4eb-44ca-abae-e81b724fc207–styles built :heavy_check_mark:

:heavy_check_mark: Nerdpack built successfully!
:heavy_multiplication_x: Error: It looks like your port 9973 is busy. The server couldn’t be started.

I was checking with lsof there is nothing running on port 9973. I explicitely restarted the computer to make sure nothing runs on that port but after restart the same. Is it possible to use some different port?


#11

I meant that I get it generated now not rendered, sorry


#12

Hi @beg1 - I’ve seen this before where there was a problem on the network, not on the specific machine that was blocking port 9973.

I’m afraid it’s not possible to dictate that the CLI uses a different port. Could you check with your network team? Or confirm that it is indeed a network issue by connecting to a different network, perhaps a mobile wifi hotspot, and see if that works?


#13

ah, if somewhere on the network port 9973 is in use, I wil get what I got? We have a very big developer network. Hard to find out. Will see, how I can isolate my computer to test it


#14

tried to deactivate my network. All ip connections are dead now. Can’t open any web page. But still the 9973 port busy problem


#15

Hey @beg1 -

That’s still kind of expected - if the CLI has no access to port 9973, it assumes it is busy, and you get the error that you see.

Disconnecting your machine from the network may not help, because then it can’t access a port 9973 on the network. Again it assumes the port is busy.

Could you try connecting your computer to a different network, not completely disconnected, but not on the original network you were on. That would help confirm things here.


#16

finally we made that running opening a wifi hotspot with a phone and connecting to that hotspot with the notebook. And this way we can run the nr1 server and connect the browser to it. A bit strange but possible to develop a widget this way. Thanks to your help


#17

Thanks for the info @beg1 - That confirms that it is something within your corporate network.

We were historically using a more widely used port, but that was clashing a lot with Docker and some other services that used those general ports. We went for 9973 as we felt it was not well used by other services.

We have no way to dictate that the CLI uses another port, but you may be able to get that opened up by working with your IT Network admins


#18

my suspicion is that simply some team at our company (we are like 300 developers in total) is running newrelic server. Would be the easiest explication because actually newrelic is quite intensively used at our company. Even though I never heart of someone trying to develog custom widget as we aim at. And my colleagues neither. But no prob. We can focus now on the business logic of the widget we want to build with newrelic. That’s the important point


#19

Understood! At least you’re able to start developing Nerdpacks now :smiley:

Let us know what you come up with when you’re done!


#20

Hi, finished some sophisticated nerdlet widget now that looks very good to us. Was able to figure out how to publish, deploy and subscribe to it., so tha now we see a button of that widget appearing at https://one.eu.newrelic.com (redirects to https://one.eu.newrelic.com/launcher/nr1-core.home#pane=eyJuZXJkbGV0SWQiOiJucjEtY29yZS5ob21lLXNjcmVlbiJ9).
And I feel I understood the DEV, STABLE and BETA channels and how to publish/subsribe some version of nerdlet to one of them. So far, all very nice and working.
But what we still miss is how to get that widget into our main Market Logic new relic page (https://insights.eu.newrelic.com/accounts/2311265/dashboards/8492). In that page we have some NRQL based dashboards. But the nerdlet widget is much better and we would like to replace some of the query based simple dashboards with it.
But I can’t see, how to add it to the page. When I switch on editing mode and try to add something, I am only given options Markdown or query based dashboard. Seems not be possible here to add some nerdlet, we already subsribe to.
Of course I could use react to display the whole page mixing some query based dashboards and our sophisticated widget(s). But doing so, each change (e.g. of some dashboard’s NRQL) would require changing some react code, testing locally, publishing, subsribing. But we would like to change simple stuff by new relic’s website simply. And we would like everyone of our group to be able to do it without changing the nerdlet’s react code. There are group members that don’t understand how to do react.
Hope you understood what I mean.
Any chance?