Usage alert not triggering

Alerts Question Template

Please describe what you are seeing, and how does this differ from what you were expecting to see?
In the Condition editor i can clearly see that my query is matching the condition but I am not getting an alert by slack or mail.

If you aren’t seeing a violation when you think there should be one, provide a link to the alert condition that should be opening a violation and to the entity that is misbehaving, scoped to the relevant time window.
condition window

1 Like

I have the same problem :frowning:

1 Like

I have the same problem. New Relic I think this is a problem on your end, this is very disappointing.

1 Like

Hi folks, sorry to hear you are running into challenges with your alerts.

  • @jan.desmet_1 it looks like you have deleted your condition, please let me know if you create another one and want me to take a look at it for you.
  • @santiago11 and @yoavzimmerman can you please paste a link to some example conditions, I’ll be happy to do some initial investigation.
1 Like

Thanks @santiago11, I see @hross is already following up on your linked thread, so I’ll check in with her and see if I can help in any way.

Hi,

it would be this condition:

condition

1 Like

Can you please try updating your Offset evaluation by setting (available when you expand the Advanced signal settings section in your Alert Condition) to 20 minutes? After saving your condition please wait for around an hour to see if a violation is generated. I’m interested to hear if this helps!

Note: there is a tip recommending this in the documentation but I can understand how this could easily be missed or misunderstood. If this turns out to have been the cause, I’ll speak with our documentation team about how we can highlight this setting more clearly.

Hi,

Only the offset value or the aggregationwindow aswell? :slight_smile:

Sorry @jan.desmet_1, I missed your last reply. If you have migrated to New Relic One Streaming Alerts then you can also update the window width. I had success with the following setting:

  • Aggregation window: 3 minutes
  • Offset evaluation by: 20 windows

Please let me know how you go with this!

1 Like

I am also having this issue. I have tried all kinds of different settings including with the offset. A co-worker and I have spend a lot of time trying to get this working but have had no luck.

The slack test message works fine, but I have configured an email too just in case that is the problem. I don’t think it is, since no incidents are generated.

We suspected based on manual queries that even though the chart knows the most recent data, the query somehow does not, so we have also tried with everything from “at least once in 1 minute” to “at least once in 120 minutes” and things in between. Nothing we’ve tried has worked and it doesn’t seem like it should be this hard.

If @nlidbury or someone else with access looks it is the “NR Daily GB Alert” condition on the “NR Cost Alert” policy.

Hey @wmosher, sorry to hear you’re not having much luck. Can you please post a link to the condition here, or DM it to me? Thanks!

I DM’d you on February 16th, but nothing came of it. How can I get support on this issue?