Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

Warning: Skipping instrumented function: pid mismatch log flooding

apm

#1

Please share your agent version and other relevant versions below:

New Relic 8.6.0.238 (“flax” - “ea460dbe0dda”)
PHP-FPM 7.3.4-1+ubuntu18.04.1+deb.sury.org+3
Linux 4.14.65+ #1 SMP Thu Oct 25 10:42:50 PDT 2018 x86_64 x86_64 x86_64 GNU/Linux

Running on GKE 1.11.x if that matters.

Please share your question/describe your issue below. Include any screenshots that may help us understand your question:

Newrelic application logs are filling with errors such as:

2019-04-16 05:37:50.524 +0000 (4562 4562) warning: Skipping instrumented function: pid mismatch, got 4563, expected 4562
2019-04-16 05:37:50.526 +0000 (4564 4564) warning: Skipping instrumented function: pid mismatch, got 4563, expected 4564

Hundreds of errors fill the logs in a second and then nothing for another minute.

PHP-FPM is set to dynamic process manager and PIDs come and go. PIDs match PHP-FPM child processes, but clearly not the ones the NR daemon wants.

Is there a configuration option I can modify? Is the application monitoring software fully tested with PHP 7.3.x ? These issues were not present when our application ran on PHP 7.0.


#2

Hi @raywalker

The messages you’re seeing is something we put in place in version 8.6.0.238 of the PHP Agent. We resolved an issue where a potential segfault could occur when using PHP 7.3, Opcache, and multiple PHP workers.

The warning is indicating that the PHP Agent caught a potential problem due to changes in Opcache in 7.3. This should not have a noticeable impact on your data collection but some details about certain functions in transaction traces may not available. With that said, you can disregard the warning.

Let me know if there is anything else I can clarify here.


#3

Thanks Priscilla,

I’m glad it’s a stability feature, but is there any way I can turn the log messages off, other than setting the agent loglevel above warning?

Hundreds of messages in a second for a hundred containers sent to our log aggregator for data which is apparently unactionable seems a waste of cycles, bandwidth and ultimately, money.


#4

Hi @raywalker,

Other than changing the loglevel, you could also disable OPcache to prevent those errors from showing up. I will be sure to let the team know why those messages may be troublesome for you, so we can discuss potential different options in the future.

Let me know if there are any other questions I can answer!


#5

Thanks again. Disabling opcache on production services doesn’t seem a viable solution. I’ll increase NR error reporting level and await an update on this issue.


#6

Thanks for posting the issue already raywalker :slight_smile: We are also encountering this error in production and it is generating enormous log files. We’ll also increase the loglevel pending an update on this issue.


#7

Thanks for letting us know you ran into this too @dnewman1!

We have filed something internally to track this. Let us know if any other questions come up!