Your data. Anywhere you go.

New Relic for iOS or Android


Download on the App Store    Android App on Google play


New Relic Insights App for iOS


Download on the App Store


Learn more

Close icon

When you can't access some admin features and the owner of your Account has a herokumanager.com domain

heroku
partnerships
partner

#1

Heroku users that log into their New Relic account through an “Organization owned Heroku application” may find that they have a User role on their New Relic account and that the Owner is something like: herokuaccountname@herokumanager.com

It may look strange, but the @herokumanager.com user is important to keep the integration running smoothly. If you are an Admin on the Heroku Organization or a Collaborator on the specific app, you can log a ticket with New Relic support, and we will update you to be an admin on your New Relic account.


Authorization for Heroku users
#2

We’re running into this issue, but cannot file support tickets (we’re still evaluating APM solutions, and are using Wayne for now). Is there any other way to get admin access to the account?


#3

Hey @matt.sills - I just manually created a ticket for you. Please be on the lookout for an email from us. We will help get you sorted as soon as possible.


#4

We have this same issue in our Heroku organization and can’t find a way to file a ticket to gain the ownership status like instructed here.

Thanks for your help @hross !


#5

Hi there @viljami.kuosmanen - You should definitely be able to file a ticket if you have a Heroku account, but I created one for you so we can get you sorted. Let’s make sure that we figure out why you can’t open a ticket too!


#6

I have a similar issue as a number of other posters - unable to find a place to log a support ticket requesting this change. I tried upgrading from wayne to hawke temporarily, but still was unable to file a support ticket. How can I get my new relic user account changed to owner?


#7

Hi @edwardjstone, sorry you had trouble filing a ticket with us! I checked your accounts and saw that they indeed appear to be Heroku organization accounts (with the @herokumanager owner). As the original post describes, having that user as the owner is important for the integration.

However, we can certainly help update you to an admin! I’ll get a ticket open so we can begin the process. Keep an eye out for an email from us. :mailbox_with_mail:


#8

I’m an admin on the Heroku Organization and have the same problem - I don’t have admin rights in my New Relic account. Would anyone mind filing a support ticket for me?:innocent:

The New Relic-Heroku integration seems to be messed up. Why do I have to register to the forum and ask someone else to file the ticket for me?


#9

Hey there @babca - that is definitely an issue. Sorry that you are having problems, but I will get a ticket started for you and we’ll get you taken care of. Be on the lookout for an email from our support team!


#10

Resolved! Thank you @hross !


#11

Good news! Let us know if you need anything else!


#12

Same problem here, cannot find a place to file a ticket. I am an admin of a Heroku organization and would like to be made admin on the newrelic page for one of the apps. Where do I file this ticket?


#13

Boom! :boom: Ticket created for you, @fredrik.blomqvist.95! Check your email and let me know once you get all sorted!


#14

It’s all sorted now, thank you so much!


#15

Happy to hear that, @fredrik.blomqvist.95 !

We are here whenever you need us! :thumbsup:


#16

I need help too:

  1. cannot find a place to raise a support ticket
  2. cannot set alerts in my new relic accounts related to Heroku (I’m a regular user in New Relic).

Please help.


#17

Hey @jacek.jaroczynski! Sorry to hear that you can’t seem to set alerts in your Heroku related accounts.

I am happy to connect you with the people who can help. Will you please reply with a permalink so we can look into your account a bit easier?. Unless of course you have made some headway by now—I see it’s been a few days since you posted this.

Hope to hear back soon!


#18

Hi @Linds,

The problem is still there.
Here is the account link: https://rpm.newrelic.com/accounts/1822517/applications

I own few other accounts (created for few other Heroku apps) and they all behave the same. They are very limited in functionality even in the initial trial period.
I tried upgrading the account from the Heroku side but it didn’t help.

Thanks,
Jacek


#19

Hi @jacek.jaroczynski,

For organization-owned Heroku applications like yours, users are created at the “User” level on the corresponding New Relic account. If you’d like to be promoted to Admin on any of these New Relic accounts, let us know. We can verify with our counterparts at Heroku that you have that level of access.

We recently made a change that removed Alerts from accounts that do not have a paid subscription, including New Relic accounts created via the Heroku “Wayne” plan. The official announcement is in this post.

Updating your user to be an admin would give you access to manage other users and other permissions on accounts, regardless of whether they are paid. However, Alerts will only be available on paid New Relic accounts.

I hope that helps to clarify, please let us know if you have any other questions.


#20

@rknotts, thank you for an explanation.

I’m happy to pay for more advanced features, especially alerting, so…

Yes, I would like to become an admin of my accounts. Here is the list:

Too bad it is a manual process. It would be great if the integration recognized Heroku access rights and granted admin permission in New Relic straight away.

I will create more Heroku apps within this organization in the future, and as far as I understand, I will need to ask for a user->admin promotion for all of them separately. Am I right?

When comes to the Alerting not accessible on Wayne plan, I tried an upgrade to Drake plan for a day, but it did not help. I suspect that lack of “admin” permission was the culprit.

I’m looking forward to hearing back from you.

Thanks,
Jacek